计算机学院大学生程序设计竞赛(2015’12)The collector’s puzzle

24 篇文章 0 订阅
21 篇文章 0 订阅

The collector’s puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 986    Accepted Submission(s): 217


Problem Description
There is a collector who own many valuable jewels. He has a problem about how to store them. There are M special boxes. Each box has a value. And each of the N jewels has a value too. 
The collector wants to store every jewel in one of the boxs while minimizing the sum of difference value. 
The difference value between a jewel and a box is: |a[i] - b[j]|, a[i] indicates the value of i-th jewel, b[j] indicates the value of j-th box.
Note that a box can store more than one jewel.

Now the collector turns to you for helping him to compute the minimal sum of differences.
 

Input
There are multiple test cases.
For each case, the first line has two integers N, M (1<=N, M<=100000).
The second line has N integers, indicating the N jewels’ values.
The third line have M integers, indicating the M boxes’ values.
Each value is no more than 10000.
 

Output
Print one integer, indicating the minimal sum of differences.
 

Sample Input
  
  
4 4 1 2 3 4 4 3 2 1 4 4 1 2 3 4 1 1 1 1
 

Sample Output
  
  
0 6
千万不要读错题,盒子的容量是无限的
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <list>
#define LL long long
#define INF 0x3f3f3f3f

using namespace std;

int a[100100],b[100100];

int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int i=0;i<m;i++)
            cin>>b[i];
        sort(a,a+n);
        sort(b,b+m);
        int ans = 0;
        int i=0, j=0;
        while(i<n && j<m)
        {
            if(a[i] <= b[j])
            {
                if(j >= 1)
                {
                    if(a[i] - b[j-1] >= b[j] - a[i])
                        ans += (b[j] - a[i++]);
                    else
                        ans += (a[i++] - b[j-1]);
                }
                else
                    ans += (b[j]-a[i++]);
            }
            else j++;
        }
        while(i < n)
            ans += fabs(a[i++] - b[m-1]);
        cout<<ans<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值