HDU 5631 (BestCoder Round #73 (div.1) 1001)Rikka with Graph(并查集)

12 篇文章 0 订阅
5 篇文章 0 订阅

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 51    Accepted Submission(s): 20
Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:
Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.
Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.
It is too difficult for Rikka. Can you help her?
Input
The first line contains a number  T(T30) ——The number of the testcases.
For each testcase, the first line contains a number  n(n100) .
Then n+1 lines follow. Each line contains two numbers  u,v  , which means there is an edge between u and v.
Output
For each testcase, print a single number.
Sample Input
  
  
1 3 1 2 2 3 3 1 1 3
Sample Output
  
  
9

大致题意:

有n个点,n+1条边,最少去掉一条边使得构成的图是联通图

方法:

n个点最少是有n-1条边才能联通,所以枚举去掉一条和去掉两条的边的情况

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
//#pragma comment(linker, "/STACK:1024000000")
#define LL long long
const int mod=1e9+7;
const int INF=0x3f3f3f3f;
const double eqs=1e-9;
const int MAXN=150010;

int u[110],v[110];
int f[110];

bool Judge(int n)
{

    int num = 0;
    for(int i = 1; i <= n; i++)
        if(f[i] == i)
            num++;
    if(num == 1)
        return true;
    return false;

}

int Find(int x)
{
    return x == f[x] ? x : f[x] = Find(f[x]);
}
void Init(int n)
{
    for(int i=0;i<=n;i++)
        f[i] = i;

}

void Link(int a, int b)
{
    int fx = Find(a);
    int fy = Find(b);
    if(fx != fy)
        f[fx] = fy;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        int ant = 0;
        scanf("%d",&n);
        for(int i=0; i<=n; i++)
        {
            scanf("%d %d",&u[i],&v[i]);
        }
        for(int i=0; i<n; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                Init(n);
                for(int k=0; k<=n; k++)
                {
                    if(k!=i && k!=j)
                        Link(u[k], v[k]);
                }

                if(Judge(n))
                    ant++;
            }
        }
        for(int i=0;i<=n;i++)
        {
            Init(n);
            for(int j=0;j<=n;j++)
            {
                if(i!=j)
                {
                    Link(u[j], v[j]);
                }

            }if(Judge(n))
                    ant++;
        }
        printf("%d\n",ant);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值