PAT_a1065 A+B and C (64bit)

题目描述

作者: HOU, Qiming
单位: 浙江大学
时间限制: 400 ms
内存限制: 64 MB
代码长度限制: 16 KB

Given three integers A, B and C in [−2​63​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one lineCase #X: true if A+B>C , or Case #X: falseotherwise, where X is the case number (starting from 1).
Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

解题思路

参考了胡凡《算法笔记上级训练指南》
题中给出的范围是[−2​63​,2​63​​],但是经过测试,发现测试点中并没有A或者B取到263的情况,因此题中范围描述应该是[−2​63​,2​63​)才符合情况,否则需要使用带负数的大整数运算。(因为long long int存储263时会自动变成-263,无法区分是否溢出)。

由于会出现溢出的情况,所以我们可以直接判断溢出情况和不溢出情况来分类即可。

不溢出
直接计算A+B与C的大小关系即可

溢出

  • A+B≥263时,显然A+B>C,但此时A+B正溢出,此时A+B<0;
  • A+B<-263时,显然A+B<C,但此时A+B负溢出,此时A+B≥0;

具体细节的处理见以下代码

#include <cstdio>

int main() {
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		long long a, b, c;
		scanf("%lld %lld %lld", &a, &b, &c);
		long long sum = a + b;
		if (a > 0 && b > 0 && sum < 0) {
			printf("Case #%d: true\n", i + 1);
		}
		else if (a < 0 && b < 0 && sum >= 0) {
			printf("Case #%d: false\n", i + 1);
		}
		else if (sum > c) {
			printf("Case #%d: true\n", i + 1);
		}
		else {
			printf("Case #%d: false\n", i + 1);
		}
	}
	return 0;
}

需要注意的地方

A+B必须存放到long long 型变量中才可以与C比较,而不可以直接在if条件中直接相加后比较,否则会出错(这里还不知道原因)

参考

C语言的整型溢出问题 int、long、long long取值范围 最大最小值
原码, 反码, 补码 详解

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值