1002 A+B for Polynomials (25 分)
This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
题型分类:数学运算
题目大意: 计算A+B的多项式,输出要求精确到1位小数。
解题思路:创建一个数组poly,下标为指数项(exponent),值为系数(coefficient)。采用边输入边处理的方式,输入一个系数就让数组对应指数下标的值加上这个系数。注意:最终输出时不要输出系数为0的项。
#include <cstdio>
const int maxn = 1010;
double poly[maxn];
int main(int argc, char** argv) {
int K, expo;
double coef;
for(int i = 0; i < 2; i++){
scanf("%d", &K);
for(int j = 0; j < K; j++){
scanf("%d %lf", &expo, &coef);
poly[expo] += coef;
}
}
int cnt = 0;
for(int i = maxn; i >= 0; i--){
if(poly[i] != 0){
cnt++;
}
}
printf("%d", cnt);
for(int i = maxn; i >= 0; i--){
if(poly[i] != 0){
printf(" %d %.1f", i, poly[i]);
}
}
return 0;
}