1016 Phone Bills (25 分)
A long-distance telephone company charges its customers by the following rules:
Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.
Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.
The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.
The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm
), and the word on-line
or off-line
.
For each test case, all dates will be within a single month. Each on-line
record is paired with the chronologically next record for the same customer provided it is an off-line
record. Any on-line
records that are not paired with an off-line
record are ignored, as are off-line
records not paired with an on-line
record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.
Output Specification:
For each test case, you must print a phone bill for each customer.
Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm
), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.
Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80
题型分类:快乐模拟
题目大意:匹配每个人的账单,筛除无效数据(只有on-line或者只有off-line)。最后对每个人的账号进行输出,并计算总额。账单按字母序进行输出。
解题思路:使用sort进行排序。
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 1010;
typedef struct {
char name[25];
int month, day, hour, minute;
int totalMinute; //用分钟表示,初始时刻从1日0点开始
bool state; //true表示on-line, false表示off-line
} record;
record rec[maxn];
int rate[24];
int convertToMinute(int dd, int hh, int mm);
bool cmp(record a, record b);
double calculateFee(record a, record b);
int main(int argc, char** argv) {
for(int i = 0; i < 24; i++) { //输入rate数组的数据
scanf("%d", &rate[i]);
}
int N;
scanf("%d", &N);
for(int i = 0; i < N; i++) { //输入数据
scanf("%s %d", rec[i].name, &rec[i].month);
char state[10]; //用来临时存储online或者offline
scanf(":%d:%d:%d %s", &rec[i].day, &rec[i].hour, &rec[i].minute, state);
rec[i].totalMinute = convertToMinute(rec[i].day, rec[i].hour, rec[i].minute);
if(strcmp(state, "on-line") == 0) {
rec[i].state = true;
}else{
rec[i].state = false;
}
}
sort(rec, rec + N, cmp);
double totalAmount = 0;
bool printName = false;
for(int i = 0; i < N; i++) {
if(i == N - 1 || strcmp(rec[i].name, rec[i + 1].name) != 0) {
if(printName == true) {
printf("Total amount: $%.2f\n", totalAmount);
}
totalAmount = 0;
printName = false;
}
else { //前后两个名字相同
if(rec[i].state == true && rec[i + 1].state == false) { //前一个记录是on-line,后一个数据是off-line
if(printName == false) { //如果还未输出过名字和月份
printf("%s %02d\n", rec[i].name, rec[i + 1].month);
printName = true;
}
printf("%02d:%02d:%02d", rec[i].day, rec[i].hour, rec[i].minute);
printf(" %02d:%02d:%02d", rec[i + 1].day, rec[i + 1].hour, rec[i + 1].minute);
printf(" %d", rec[i + 1].totalMinute - rec[i].totalMinute);
double amount = calculateFee(rec[i], rec[i + 1]);
totalAmount += amount;
printf(" $%.2f\n", amount);
}
}
}
return 0;
}
int convertToMinute(int dd, int hh, int mm) {
return (dd - 1) * 24 * 60 + hh * 60 + mm;
}
bool cmp(record a, record b) {
if(strcmp(a.name, b.name) != 0) return strcmp(a.name, b.name) < 0;
else return a.totalMinute < b.totalMinute;
}
double calculateFee(record a, record b) {
double amount = 0;
while(a.day != b.day || a.hour != b.hour || a.minute != b.minute){
amount += 1.0 * rate[a.hour] / 100.0;
a.minute++;
if(a.minute == 60){
a.minute = 0;
a.hour++;
if(a.hour == 24){
a.hour = 0;
a.day++;
}
}
}
return amount;
}