1029 Median

1029 Median (25 分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​^5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13


题型分类:数学问题

题目大意:给出两个非递减的数列,找出总数列的中位数

解题思路:将两个队列合并成一个队列排序可能会超时(没有试,猜的,感觉题目不会这么简单)。所以第一个队列入队以后,对第二个队列进行处理,如果确定不是中位数就直接不入队,节约空间。这里有一个比较好的处理方法就是在队列的最后加一个无穷大的数,这样队列空了以后就不通特殊处理了。


#include <cstdio>
#include <queue>
#include <algorithm>

using namespace std;

const int INF = 0x3f3f3f3f;

queue<int> q1, q2;

int main(int argc, char** argv) {
	int N1, N2, temp;
	scanf("%d", &N1);
	for(int i = 0; i < N1; i++){
		scanf("%d", &temp);
		q1.push(temp);
	}
	q1.push(INF); //将INF进队,这样在下面的比较时,就不会出现空队的情况,方便处理
	scanf("%d", &N2);
	int cnt = (N1 + N2 - 1) / 2; //cnt表示中位数的位置
	for(int i = 0; i < N2; i++, cnt--){
		scanf("%d", &temp);
		q2.push(temp);
		if(cnt > 0){ //找到中位数,不用再比较了
			if(q1.front() < q2.front()) q1.pop();
			else q2.pop();
		}
	}
	q2.push(INF);
	for(; cnt > 0; cnt--){ //有可能q2全部出队以后还没有找到中位数
		if(q1.front() < q2.front()) q1.pop();
		else q2.pop();
	}
	printf("%d", min(q1.front(), q2.front()));
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值