POJ 1017 Packets 贪心

Packets
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 53481 Accepted: 18185

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

Source


题目大意是有六种型号的包裹,试问用几个6*6的大包裹可以将给定的包裹放在里面。

贪心的思路就是从型号最大的开始枚举,6,5,4三种型号分别需要占用一个大包裹。3号讨论一下剩余的情况(每4个3号的占用一个大包裹)。之后再放2,1型号的。

五组数据,仅供参考

0 0 4 0 0 1 
7 5 1 0 0 0 
8 5 1 0 0 0
65 65 513 1 8 8
58 63 33 3 3 3


2
1
2
153
24

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    int a, b, c, d, e, f;
    int no[4] = {0, 5, 3, 1};
    while(scanf("%d%d%d%d%d%d", &a, &b, &c, &d, &e, &f) != EOF) {
        if(a == 0 && b == 0 && c == 0 && d == 0 && e == 0 && f == 0) {
            break;
        }
        int ans = f + e + d + (c + 3) / 4;  //目前的大包裹数
        int temp = 5 * d + no[c % 4];       //2号包裹可用的空余位置
        if(b >= temp) {
            ans += (b - temp + 8) / 9;      
        }
        temp = ans * 36 - f * 36 - e * 25 - d * 16 - c * 9 - b * 4; //1号包裹可用的空余位置
        if(a >= temp) {
            ans += (a - temp + 35) / 36;
        }
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值