B - Can you solve this equation?

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky. Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2
100
-4
Sample Output

1.6152No solution!

开始就觉得解方程应该通过具体的数据直接确定解的位置,但就是没想到通过二分法不断靠近解的位置,当到达一定精度时就能得到解,而且关于二分过程中上下限的更新也和一般的二分查找不一样;在确定上下限的范围过程中,这个范围的大小就要够小,不然当y很大时精度不对

#include<cstdio>
#include<cmath>
#define le 1e-8//le至少要到1e-8,不然在y等于100时会出错
double f(double x)
{
    return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double sum;
        scanf("%lf",&sum);
        if(sum<f(0)||sum>f(100)){printf("No solution!\n");}
        else{
        double mid,low=0,high=100.0;
        while(high-low>le)//将解所在的范围不断缩小,注意low,high的更新
        {
            mid=(low+high)/2.0;
            if(f(mid)<sum)low=mid;
            else high=mid;
        }
        printf("%.4lf\n",low);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值