Idiomatic Phrases Game 成语接龙 dijstra

Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.

Input

The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.

Output

One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.

Sample Input

5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0

Sample Output

17
-1

 

 

题目中给的都是成语之间的关系,而且每个汉字都是由四个字符组成的

所以关键是如何由这些成语间的关系来建图

而且我看到这个题的第一想法就是dfs,然后就只是把成语间的关系存储,并没有建图。然后果断tle了,下面是tle代码

#include <bits/stdc++.h>
using namespace std;
#define inf 0x3f3f3f3f
int n,ans,vis[1111];
struct node{
    char a[5],b[5];
    int ti;
}str[2000];
void dfs(int x,int em)
{
    if(strcmp(str[x].b,str[n-1].a)==0){
        if(em+str[x].ti<ans)ans=em+str[x].ti;
        return;
    }
    for(int i=1;i<n;i++){
        if(strcmp(str[i].a,str[x].b)==0&&!vis[i]){
            if(em+str[x].ti>ans)continue;
            vis[i]=1;
            dfs(i,em+str[x].ti);
            vis[i]=0;
        }
    }
    return;
}
int main()
{
	char vo[2000];
	while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<n;i++)
        {
            int t;scanf("%d %s",&t,vo);
            str[i].a[0]=vo[0];str[i].a[1]=vo[1];str[i].a[2]=vo[2];str[i].a[3]=vo[3];
            int L=strlen(vo);
            str[i].b[3]=vo[L-1];str[i].b[2]=vo[L-2];str[i].b[1]=vo[L-3];str[i].b[0]=vo[L-4];
            str[i].ti=t;
        }
        ans=inf;
        memset(vis,0,sizeof vis);
        dfs(0,0);
        if(ans==inf)printf("-1\n");
        else printf("%d\n",ans);
    }
}

后来也想到了建图,用dijstra,但图有问题,wa了,

然后下面是错误的见图demo

 


int main()
{
	char vo[2000],tem[4];string str;
	while(~scanf("%d",&n)&&n)
    {
        L=0;int x,y,aid;it.clear();
        memset(a,0x3f3f3f3f,sizeof a);
        memset(vis,0,sizeof vis);
        for(int ii=0;ii<n;ii++)
        {
            int t;scanf("%d %s",&t,vo);
            for(int i=0;i<4;i++)str+=vo[i];
            if(it.count(str)==0){
                it[str]=L++;
            }
            x=it[str];
            str.clear();
            int len=strlen(vo);
            for(int i=len-4;i<len;i++)str+=vo[i];
            if(it.count(str)==0){
                it[str]=L++;
            }
            y=it[str];
            a[x][y]=t;
            str.clear();
            if(ii==n-1)
                aid=x;
        }
        dijstra();
        printf("%d\n",dis[aid]==inf?-1:dis[aid]);
    }
}
这样建的图根本就是成语本身的联系

ac demo

 

#include <bits/stdc++.h>
using namespace std;
#define inf 0x3f3f3f3f
int n,ans,vis[1010],a[1010][1010],dis[1010];
map<string,int>it;
struct node{
    char a[5],b[5];int t;
}st[1010];
void dijstra()
{
    for(int i=0;i<n;i++)
        dis[i]=a[0][i];
    for(int i=1;i<n;i++)
    {
        int tmin=inf,k=-1;
        for(int j=1;j<n;j++)
        {
           if(!vis[j]&&tmin>dis[j]){
            tmin=dis[j];k=j;
           }
        }
        if(k==-1)return;
        vis[k]=1;
        for(int j=1;j<n;j++){
            if(dis[k]+a[k][j]<dis[j]){
                dis[j]=dis[k]+a[k][j];
            }
        }
    }
}
int main()
{
	char vo[2000];string str;
	while(~scanf("%d",&n)&&n)
    {
        int x,y;it.clear();
        memset(a,0x3f3f3f3f,sizeof a);
        memset(vis,0,sizeof vis);
        for(int i=0;i<n;i++)
        {
            int t;scanf("%d %s",&t,vo);
            st[i].a[0]=vo[0];st[i].a[1]=vo[1];st[i].a[2]=vo[2];st[i].a[3]=vo[3];st[i].a[4]='\0';
            int L=strlen(vo);
            st[i].b[0]=vo[L-4];st[i].b[1]=vo[L-3];st[i].b[2]=vo[L-2];st[i].b[3]=vo[L-1];st[i].b[4]='\0';
            st[i].t=t;
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++){
                if(strcmp(st[i].b,st[j].a)==0)
                    a[i][j]=st[i].t;
            }
        }
        dijstra();
        printf("%d\n",dis[n-1]==inf?-1:dis[n-1]);
    }
}

这个题所获最多的还是这种见图经验

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值