1066 Root of AVL Tree (25分)

2 篇文章 0 订阅

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

fig1
fig2
fig3
fig4
Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

题目大意

给定一个插入序列,要求调整为AVL树,然后输出根结点的值

分析

构建二叉排序树,然后根据平衡因子左右旋调整二叉树,左后输出根节点的值

注意

在左右旋之后要改变root=temp,不是temp=root;

//1066 Root of AVL Tree (25分) 
#include <iostream>
using namespace std; 
struct node
{
	int v,height;
	node *lchild,*rchild;
};
int getHeight(node *root)
{
	if(root==NULL)
		return 0;
	return root->height;
}
int getBalanceFactor(node *root)
{
	return getHeight(root->lchild)-getHeight(root->rchild);
}
void updateHeight(node *root)
{
	root->height=max(getHeight(root->lchild),getHeight(root->rchild))+1;
}
void L(node* &root)
{
	node* temp=root->rchild;
	root->rchild=temp->lchild;
	temp->lchild=root;
	updateHeight(root);
	updateHeight(temp);
	root=temp;//将root结点更新 
}
void R(node* &root)
{
	node* temp=root->lchild;
	root->lchild=temp->rchild;
	temp->rchild=root;
	updateHeight(root);
	updateHeight(temp);
	root=temp;
}
void insert(node* &root,int x)
{
	if(root==NULL)
	{
		node *newNode=new node;
		newNode->v=x;
		newNode->height=1;
		newNode->lchild=newNode->rchild=NULL;
		root=newNode;
		return ;
	}
	if(x<root->v)
	{
		insert(root->lchild,x);
		updateHeight(root);
		if(getBalanceFactor(root)==2)
		{
			if(getBalanceFactor(root->lchild)==1)
			{
				R(root);
			}
			else if(getBalanceFactor(root->lchild)==-1)
			{
				L(root->lchild);
				R(root);
			}
		}
	}
	else
	{
		insert(root->rchild,x);
		updateHeight(root);
		if(getBalanceFactor(root)==-2)
		{
			if(getBalanceFactor(root->rchild)==-1)
			{
				L(root);
			}
			else if(getBalanceFactor(root->rchild)==1)
			{
				R(root->rchild);
				L(root);
			}
		}
	}
}
int main() 
{
	int n;
	cin>>n;
	node *tree=NULL;
	for(int i=0;i<n;i++)
	{
		int data;
		cin>>data;
		insert(tree,data);
	}
	cout<<tree->v;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值