1069 The Black Hole of Numbers (20分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

题目大意

输入一个四位整数,数字递减排列-数字递增排列的=某个值,在用这个值继续执行这种操作,直到结果位6174或者为0000,输出整个运算过程

分析

定义string str用于保存四位整数,如果不足四位前补零,然后用sort对字符串进行递增递减排列求值,直到结果为0000或者为6174停止

注意

对于字符转数字并且还要重新排列的一定要注意前导0

//1069 The Black Hole of Numbers (20分)
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
bool cmp(char a,char b)
{
	return a>b;
}
int main()
{
	string str;
	cin>>str;
	str.insert(0,4-str.length(),'0');//如果输入的不是4位数,需要前导0 
	while(1)
	{
		sort(str.begin(),str.end(),cmp);
		string str1=str;
		sort(str.begin(),str.end());
		string str2=str;
		int res=stoi(str1)-stoi(str2);
		printf("%s - %s = %04d\n",str1.c_str(),str2.c_str(),res);
		if(res==0||res==6174)
		{
			break;
		}
		str=to_string(res);
		str.insert(0, 4 - str.length(), '0');
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值