1152 Google Recruitment (20分)

3 篇文章 0 订阅

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google’s hiring process by visiting this website.

prime.jpg

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921… where the 10 digits in bold are the answer to Google’s question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

题意

输入l,k,求一个l长的数字的第一个长度为k的素数

分析

数字以字符串的形式存储,每次截取k个字符转化为整形,判断是否为素数

注意

不知道为什么str.size()-k有个样例过不了,l-k就可以,截取时长度一定要够,
素数的判断注意先特殊处理x<=1

//1152 Google Recruitment (20分)
#include <iostream>
#include <cmath>
using namespace std;
bool isPrime(int x)
{
	if(x==1||x==0)
		return false;
	int sqr=sqrt(x)+1;
	for(int i=2;i<sqr;i++)
	{
		if(x%i==0)
			return false;
	}
	return true;
}
int main() 
{
	string str;
	int l,k;
	cin>>l>>k>>str;
	for(int i=0;i<=l-k;i++)//str.length()-k
	{
		int num=stoi(str.substr(i,k)); 
		if(isPrime(num))
		{
			cout<<str.substr(i,k);
			return 0;
		}	
	}
	cout<<404;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值