1053 Path of Equal Weight (30 分)

35 篇文章 0 订阅
29 篇文章 0 订阅

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

写这道题真的是耗费了我大量的脑细胞,大概写了2个小时才写完,主要难点在于DFS怎么写。

  1. ”死胡同“就是到达了叶节点,但同时死胡同也是可能出口(如果权重和==Sum),要写两个if进行判断
  2. 最后输出的路径是权重值的路径,每次迭代也要累加上权重和
  3. vector<path>的存储要特别注意!注意使用完(从迭代里出来后)要及时pop_back()
  4. DFS的参数确定,非常非常重要,一般是会随着迭代(节点选取不同)改变的量
#include<cstdio>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn = 110;
int weightSum = 0;
int target;
vector<vector<int> > result;
vector<int> path;
struct node {
	int weight;
	vector<int> child;
}Node[maxn];

void DFS(int root, int weightSum) {
	//递归边界

	if (Node[root].child.empty()) {
		if (weightSum == target) {
			result.push_back(path);
		}
		return;
	}

	//不同的分支
	for (int i = 0; i < Node[root].child.size(); i++) {
		if (weightSum + Node[Node[root].child[i]].weight <= target)
		{
			path.push_back(Node[Node[root].child[i]].weight);
			DFS(Node[root].child[i], weightSum + Node[Node[root].child[i]].weight);
			path.pop_back();
		}
	}

}

bool cmp(vector<int> a, vector<int> b) {
	int i = 0;
	for (i = 0;  i < a.size() && i < b.size() && a[i] == b[i] ;i++) {
	}
	if (!(i < a.size() && i < b.size())) {
		return a.size() > b.size();
	}
	return a[i] > b[i];
}

int main() {
	int N, M;
	scanf("%d%d%d", &N, &M, &target);
	for (int i = 0; i < N; i++)
		scanf("%d", &Node[i].weight);
	for (int i = 0; i < M; i++)
	{
		int root, childNum;
		scanf("%d%d", &root, &childNum);
		for (int j = 0; j < childNum; j++) {
			int tmp;
			scanf("%d", &tmp);
			Node[root].child.push_back(tmp);
		}
	}

	path.push_back(Node[0].weight);
	DFS(0, Node[0].weight);
	sort(result.begin(), result.end(), cmp);
	for (int i = 0; i < result.size(); i++)
	{
		for (int j = 0; j < result[i].size(); j++)
		{
			if(j == 0)
				printf("%d", result[i][j]);
			else
				printf(" %d", result[i][j]);
		}
		printf("\n");
	}
	return 0;
}

 

 

在解决算法题目“Powers of Two”时,如果需要查找二进制表示中连续1的数量,可以利用C++标准库中的`std::equal_range`函数。这个函数用于在一个已排序范围内查找两个元素,这两个元素使得所有小于第一个元素的值都小于第二个元素,并且两者之间的范围是连续的。 假设我们有一个包含正整数的数组`arr[]`,我们要找出其中所有等于2的幂次方的索引。我们可以这样做: ```cpp #include <vector> #include <algorithm> // 定义一个函数找到powers_of_two的索引范围 std::pair<int, int> findPowerOfTwo(std::vector<int>& arr) { std::vector<int>::iterator it = arr.begin(), end = arr.end(); // 找到第一个2的幂次方 while (it != end && *it != 1) { ++it; } if (it == end) { return {0, 0}; // 如果数组中没有2的幂次方,返回空范围 } // 使用equal_range寻找连续的2的幂次方 auto range = std::equal_range(it, end, *it); // [first, last) return {range.first - arr.begin(), range.second - arr.begin()}; } int main() { std::vector<int> powers(5, 0); for (auto& index : findPowerOfTwo(powers)) { powers[index] = 1; // 标记找到的2的幂次方位置 } // powers 数组现在应该是 [0, 0, 1, 0, 0] 或者其他表示2的幂的位置 // ... } ``` 在这个例子中,`findPowerOfTwo`函数首先找到数组中第一个2的幂次方,然后使用`std::equal_range`查找从该位置开始的所有连续的2的幂。注意,由于`equal_range`返回的是闭区间 `[first, last)`,所以我们需要减去`arr.begin()`得到实际的索引范围。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值