HDU 1002 A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 168135    Accepted Submission(s): 32205


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
   
   
2 1 2 112233445566778899 998877665544332211
 

Sample Output
   
   
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L

代码:
#include<stdio.h>
#include<string.h>
char a[1000],b[1000];
long c[1004];
int main()
{  long n,t,t1,t2,sign,i,k;
   while(scanf("%ld%",&n)!=EOF)
   {     t=0;
      while(t<n)
   {      scanf("%s%s",a,b);
          t1=strlen(a)-1;
       t2=strlen(b)-1;
        for(k=0,sign=0;t1>=0&&t2>=0;t1--,t2--,k++)
      if((a[t1]-'0')+(b[t2]-'0')+sign>=10)
      {  c[k]=((a[t1]-'0')+(b[t2]-'0')+sign)%10;
          sign=1;
       
      } 
      else
      {    c[k]=(a[t1]-'0')+(b[t2]-'0')+sign;
           sign=0; 
      }
   
             
       if(t2+1==0)
    { for(;t1>=0;t1--)
    { if(a[t1]-'0'+sign>=10)
      {  c[k++]=(a[t1]-'0'+sign)%10;
         sign=1;
       
      } 
      else
      {    c[k++]=((a[t1]-'0')+sign)%10;
           sign=0; 
      }
      
    }
    }
    else if(t1+1==0)
    {    
     for(;t2>=0;t2--)
      if((b[t2]-'0'+sign)>=10)
      {  c[k++]=(b[t2]-'0'+sign)%10;
         sign=1;
       
      } 
      else
      {    c[k++]=((b[t2]-'0')+sign)%10;
           sign=0; 
      }
    }
   
    if(sign) c[k++]=sign;
    t++;
      
    printf("Case %ld:\n%s + %s = ",t,a,b);
    for(i=k-1;i>=0;i--)
     printf("%ld",c[i]);
    if(t==n)   printf("\n");
              else printf("\n\n");
     
   }        
  }  
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值