Out of Sorts II

问题 E: Out of Sorts II

时间限制: 1 Sec  内存限制: 128 MB
提交: 441  解决: 80
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Keeping an eye on long term career possibilities beyond the farm, Bessie the cow has started learning algorithms from various on-line coding websites.
Her favorite algorithm thus far is "bubble sort". Here is Bessie's initial implementation, in cow-code, for sorting an array A of length N.

sorted = false
while (not sorted):
   sorted = true
   moo
   for i = 0 to N-2:
      if A[i+1] < A[i]:
         swap A[i], A[i+1]
         sorted = false
Apparently, the "moo" command in cow-code does nothing more than print out "moo". Strangely, Bessie seems to insist on including it at various points in her code.

After testing her code on several arrays, Bessie learns an interesting observation: while large elements can be pulled to the end of the array very quickly, it can take small elements a very long time to "bubble" to the front of the array (she suspects this is how the algorithm gets its name). In order to try and alleviate this problem, Bessie tries to modify her code so that it scans forward and then backward in each iteration of the main loop, so that both large and small elements have a chance to be pulled long distances in each iteration of the main loop. Her code now looks like this:

sorted = false
while (not sorted):
   sorted = true
   moo
   for i = 0 to N-2:
      if A[i+1] < A[i]:
         swap A[i], A[i+1]
   for i = N-2 downto 0:
      if A[i+1] < A[i]:
         swap A[i], A[i+1]
   for i = 0 to N-2:
      if A[i+1] < A[i]:
         sorted = false
Given an input array, please predict how many times "moo" will be printed by Bessie's modified code.

 

输入

The first line of input contains N (1≤N≤100,000). The next N lines describe A[0]…A[N−1], each being an integer in the range 0…109. Input elements are not guaranteed to be distinct.

 

输出

Print the number of times "moo" is printed.

 

样例输入

5
1
8
5
3
2

 

样例输出

2

双向冒泡,一次while中,第一个for将最大元素放置末尾,第二个for将最小元素放置最前面

这样模拟一下,最大while的次数是二分之一序列长度,

即只需要计算对于原来在后面而排序后在前面的那一半就好了

即,最大的,前i个中,原来不在前i个 的元素个数

这题用树状数组还有个骚操作

对于当前第i个元素,add(i.id,1)

就相当于将第i.id标记,那么query(i)就是前i个中所有标记的个数

那么前i个中原来不在前i个的元素就有i-query(i)个

所以可以

for(i=1;i<=n;i++)
{
   add(p[i].index);
   ans = max(ans,i-query(i));
}

那么代码

#include <bits/stdc++.h>
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
struct P
{
    ll a,b;
}p[100005];int vis[100008];
int cmp(P a,P b)
{
    if(a.a!=b.a)
        return a.a<b.a;
    return a.b<b.b;
}
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%lld",&p[i].a),p[i].b=i;
    sort(p,p+n,cmp);
    ll c = 0;
    ll ans = 1;
 
    for(int i=0;i<n;i++)
    {
        if(p[i].b>i)
            c++;
        if(vis[i])
            c--;
        vis[p[i].b]=1;
        ans = max(ans,c);
    }
    printf("%lld\n",ans);
 
    return 0 ;
}

 

学长的树状数组

#include<bits/stdc++.h>
#define sl(x) scanf("%lld",&x)
using namespace std;
typedef long long ll;
const int N = 1e5+5;
const ll mod = 1e9+7;
const ll INF = 0x3f3f3f3f;
ll c[N],t[N];
struct node{
    ll num,index;
}p[N];
 
bool cmp(node a,node b)
{
    if(a.num == b.num)
    return a.index < b.index;
     
    return a.num < b.num;
}
 
int lowbit(int k)
{
    return k&(-k);
}
 
void add(int k)
{
    while(k < N)
    {
        c[k] += 1;
        k += lowbit(k);
    }
}
 
ll query(int k)
{
    ll sum = 0;
    while(k)
    {
        sum += c[k];
        k -= lowbit(k);
    }
    return sum;
}
 
int main()
{
    ll n,i,j,k;
    sl(n);
    for(i = 1;i <= n;i++)
    {
        sl(p[i].num);
        p[i].index = i;
    }
    sort(p+1,p+1+n,cmp);
    ll ans = 1;
    for(i=1;i<=n;i++)
    {
        add(p[i].index);
        ans = max(ans,i-query(i));
    }
    printf("%lld\n",ans);
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值