Tautology(POJ 3295)(暴力枚举)

题目链接:http://poj.org/problem?id=3295
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12454 Accepted: 4738
Description

WFF ‘N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

p, q, r, s, and t are WFFs
if w is a WFF, Nw is a WFF
if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
w x Kwx Awx Nw Cwx Ewx
1 1 1 1 0 1 1
1 0 0 1 0 0 0
0 1 0 1 1 1 0
0 0 0 0 1 1 1
A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0
Sample Output

tautology
not
Source

Waterloo Local Contest, 2006.9.30

题解:
枚举p,q,r,s,t的可能值,如果枚举过程中有一个不行,那么就说明不行,直接退出。而实现方法是用栈,遇到运算符就把所需要的栈中元素压出来,遇到元素,就把相应的值压入栈。最后栈中剩下的元素就是结果。

思考:
1、一定要会算时间复杂度,如果时间复杂度可以,那么直接用暴力的算法就行,不用在题上浪费那么多时间
2、要学会用栈,因为这道题模拟的电脑操作,所以要想到栈

#include <iostream>
#include <string>
#include <stack>

using namespace std;

string s;

int OP (char c, int a, int b)
{
    if (c == 'K') return a & b;
    if (c == 'A') return a | b;
    if (c == 'N') return !a;
    if (c == 'C') return a <= b;
    if (c == 'E') return a == b;
}

int Count ( )
{
    int l = s.length();
    int a[10];
    for (a[0] = 0; a[0] <= 1; a[0]++) {
        for (a[1] = 0; a[1] <= 1; a[1]++) {
            for (a[2] = 0; a[2] <= 1; a[2]++) {
                for (a[3] = 0; a[3] <= 1; a[3]++) {
                    for (a[4] = 0; a[4] <= 1; a[4]++) {
                        stack<int> s1;
                        for (int i = l - 1; i >= 0; i--) {
                            if (s[i] == 'p' || s[i] == 'q' || s[i] == 'r' || s[i] == 's' || s[i] == 't') {
                                s1.push (a[s[i] - 'p']);
                            } else if (s[i] == 'N') {
                                int now = s1.top();
                                s1.pop();
                                now = !now;
                                s1.push(now);
                            } else {
                                int t1 = s1.top(); s1.pop();
                                int t2 = s1.top(); s1.pop();
                                s1.push (OP (s[i], t2, t1));
                            }
                            if (i == 0) {
                                int now = s1.top();
                                s1.pop();
                                if (now != 1) return 0;
                            }
                        }
                    }
                }
            }
        }
    }
    return 1;
}

int main()
{
    while (cin >> s)
    {
        if (s[0] == '0') break;
        int flag = Count ();
        if (flag) cout << "tautology" << endl;
        else cout << "not" << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值