HDU 1789 - Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13421    Accepted Submission(s): 7816


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5

    第一步按照reduced_score从大到小排序,如果reduced_score相等,则按照deadline从小到大排。
    然后开始选择,让当前的课排在其deadline上面,如果这一天已经被占用了,
	那么就往前循环,有位置了就安排,没了就sum+=reduced_score

#include<cstdio>
#include<algorithm>
using namespace std;
typedef struct{
	int deadline;
	int reduced_score;
}type;
type homework[1003];
int day[1100];
bool cmp(type a,type b)
{
	if(a.reduced_score == b.reduced_score) return a.deadline < b.deadline;
	return a.reduced_score > b.reduced_score;
}
int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		int deadline_max=-1;
		for(int i=1;i<=n;i++){
			scanf("%d",&homework[i].deadline);
			if(homework[i].deadline > deadline_max) deadline_max=homework[i].deadline;
		}
		for(int i=1;i<=n;i++) scanf("%d",&homework[i].reduced_score);
		sort(homework+1,homework+n+1,cmp);

		int reduced_score_sum=0;
		memset(day,0,sizeof(day));
		for(int i=1;i<=n;i++){
			int j;
			for(j=homework[i].deadline;j>=1;j--){
				if(day[j]==0){
					day[j]=1;
					break;
				}
			}
			if(j==0) reduced_score_sum+=homework[i].reduced_score; //反正分也扣了,一百年之后再做也没事,就不用去管哪天做了 
		}
		printf("%d\n",reduced_score_sum); 
	}
}


我觉得这才是名副其实的贪心……所有的作业都想办法拖到最后一天做,没办法了就往前算算有没有那天可以做的,实在不行就只能扣分了……

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值