算法笔记练习 6.4 map 问题 A: 【PAT A1071】Speech Patterns

算法笔记练习 题解合集

本题链接

题目

题目描述
People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?

输入
Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return ‘\n’. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

输出
For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

样例输入

Can1: "Can a can can a can?  It can!"

样例输出

can 5

思路

题目不难,需要注意一些细节:

  • 最后一个单词不要忘了统计;
  • 不要统计空字符串;
  • 注意大小写不敏感,所以统计之前要对字符串作小写化处理。

代码

参考柳神的代码

#include <iostream>
#include <string>
#include <cctype>
#include <map>
using namespace std;
int main() {
	string input, word, maxWord;
	while (getline(cin, input)) { 
		int p = 0, maxCnt = 0;
		map<string, int> wordCnt;
		for (int i = 0; i < input.size(); ++i) {
			if (isalnum(input[i]))
				word += tolower(input[i]);
			if (i == input.size() - 1 || !isalnum(input[i])) {
				if (!word.empty())
					++wordCnt[word];
				word.clear();
			} 
		}
		for (auto it = wordCnt.begin(); it != wordCnt.end(); ++it) {
			if (it->second > maxCnt) {
				maxCnt = it->second;
				maxWord = it->first;
			} 
		}
		cout << maxWord << " " << maxCnt;
	}
	return 0;
} 

自己写的

#include <iostream>
#include <string>
#include <cctype>
#include <map>
using namespace std;
string getWord(const string &input, int &p) {
	string word;
	while (p != input.size() && !isalnum(input[p]))
		++p;
	if (p == input.size())
		return word;
	int begin = p;
	while (p != input.size() && isalnum(input[p]))
		++p;
	word = input.substr(begin, p - begin);
	for (auto &ch : word)
		ch = tolower(ch); 
	return word;
} 
int main() {
	string input, word, maxWord;
	while (getline(cin, input)) { 
		int p = 0, maxCnt = 0;
		map<string, int> wordCnt;
		while (p != input.size()) {
			word = getWord(input, p);
			if (!word.empty()) {
				if (wordCnt.count(word))
					++wordCnt[word];
				else
					wordCnt[word] = 1;
			}
		}
		for (auto it = wordCnt.rbegin(); it != wordCnt.rend(); ++it) {
			if (it->second >= maxCnt) {
				maxCnt = it->second;
				maxWord = it->first;
			} 
		}
		cout << maxWord << " " << maxCnt;
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值