poj-1753 Flip Game

4 篇文章 0 订阅
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 34300 Accepted: 14985

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb

bbwb

bwwb

bwww

Sample Output

4

    一开始用的方法是枚举反转情况,后来发现这种方法如果不用大量空间的存储每一步出现的棋盘情况,就没法实现深搜回溯时对上一步棋面的还原。后来换了另一种枚举方法,枚举的步数。对应步数找出相应数量的棋子,同时反转,之后恢复原图。解决了之前的问题。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define INF 0x3f3f3f3f
int map[4][4],flag[4][4],mapx[4][4];
int flag1=0,k;
void fun(int step,int m)
{
        int i,j,t=0;
        if(flag1) return ;
        if(step==k)
        {
                for (i=0;i<16;i++)
                {
                        mapx[i/4][i%4]=map[i/4][i%4];
                }
                for (i=0;i<4;i++)
                {
                        for (j=0;j<4;j++)
                        {
                                if(flag[i][j])
                                {
                                        if(mapx[i][j]) mapx[i][j]=0;
                                        else mapx[i][j]=1;
                                        if(i>0)
                                            if(mapx[i-1][j]) mapx[i-1][j]=0;
                                            else mapx[i-1][j]=1;
                                        if(i<3)
                                            if(mapx[i+1][j]) mapx[i+1][j]=0;
                                            else mapx[i+1][j]=1;
                                        if(j>0)
                                            if(mapx[i][j-1]) mapx[i][j-1]=0;
                                            else mapx[i][j-1]=1;
                                        if(j<3)
                                            if(mapx[i][j+1]) mapx[i][j+1]=0;
                                            else mapx[i][j+1]=1;
                                }
                        }
                }
                for (i=0;i<4;i++)
                {
                        for (j=0;j<4;j++)
                        {
                                if(mapx[i][j]==1)
                                t++;
                        }
                }
                if(t==0||t==16) flag1=1;
                return ;
        }
        for (i=m+1;i<16;i++)
        {
                flag[i/4][i%4]=1;
                fun(step+1,i);
                flag[i/4][i%4]=0;
        }
}
int main()
{
        char c;
        int i,j;
        for (i=0;i<16;i++)
        {
                scanf("%c",&c);
                if((i+1)%4==0)    getchar();
                if(c=='b')
                {
                        map[i/4][i%4]=1;
                }
                else if(c=='w')
                {
                        map[i/4][i%4]=0;
                }
        }
        for (i=0;i<=16;i++)
        {
                memset(flag,0,sizeof(flag));
                k=i;
                fun(0,-1);
                if(flag1) break;
        }
        if(flag1) printf("%d\n",i);
        else printf("Impossible\n");
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值