HDU - 1532 Drainage Ditches

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

题解:最大流问题,图论书P271,通过在残留网络中寻找从源y到汇t的最短路径方式寻找增广路并增广,最终求网络最大流。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 210
#define inf 0x3f3f3f3f
using namespace std;
int m,n;//排水沟的数目,汇合结点数目
int y,t;//源点(结点1),汇点(结点n)
int res[N][N];//残留网络
int qu[N*N],qe,qs;//队列,队首和队尾
int pre[N];//增广路上顶点i前面的顶点序号
int vis[N];//bfs中各顶点的访问标志
int maxflow,min_augment;//最大流流量,每次增广时的可改进量
struct node//邻接矩阵,存放流,及容量
{
    int c,f;
} e[N][N];
void findd()//bfs求增广路
{
    int i,st;
    memset(vis,0,sizeof(vis));
    memset(res,0,sizeof(res));
    memset(pre,0,sizeof(pre));
    qs=0,qe=1,qu[qs]=y,vis[y]=1;
    while(qs<qe&&pre[t]==0)//不为空
    {
        st=qu[qs];//队首
        for(i=1; i<=n; i++)
        {
            if(vis[i]==0)
            {
                if(e[st][i].c-e[st][i].f>0)
                {
                    res[st][i]=e[st][i].c-e[st][i].f;
                    pre[i]=st;
                    qu[qe++]=i;
                    vis[i]=1;
                }
                else if(e[i][st].f>0)
                {
                    res[st][i]=e[i][st].f;
                    pre[i]=st;
                    qu[qe++]=i;
                    vis[i]=1;
                }
            }
        }
        qs++;
    }
}
void augflow()
{
    int i=t,j;//t为汇点
    if(!pre[i])
    {
        min_augment=0;
        return;
    }
    j=inf;
    while(i!=y)//计算增广路上可改进量的最小值
    {
        if(res[pre[i]][i]<j)
            j=res[pre[i]][i];
        i=pre[i];
    }
    min_augment=j;
}
void upflow()//调整流量
{
    int i=t;//t为汇点
    if(!pre[i])
        return;
    while(i!=y)
    {
        if(e[pre[i]][i].c-e[pre[i]][i].f>0)
            e[pre[i]][i].f+= min_augment;
        else if(e[i][pre[i]].f>0)
            e[pre[i]][i].f+= min_augment;
        i=pre[i];
    }
}
void solve()
{
    y=1,t=n;
    maxflow=0;
    while(1)
    {
        findd();//寻找增广路
        augflow();//计算可改进量
        maxflow+=min_augment;
        if(min_augment>0)
            upflow();//更新流
        else
            return;
    }
}
int main()
{
    while(~scanf("%d%d",&m,&n))
    {
        int i,j,s,E,c;
        memset(e,0,sizeof(e));
        for(i=0; i<m; i++)
        {
            scanf("%d%d%d",&s,&E,&c);
            e[s][E].c+=c;
        }
        solve();
        printf("%d\n",maxflow);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值