HDU-1728 逃离迷宫(BFS)

逃离迷宫

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 31340    Accepted Submission(s): 7672


Problem Description
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
 

Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x 1, y 1, x 2, y 2 (1 ≤ k ≤ 10, 1 ≤ x 1, x 2 ≤ n, 1 ≤ y 1, y 2 ≤ m),其中k表示gloria最多能转的弯数,(x 1, y 1), (x 2, y 2)表示两个位置,其中x 1,x 2对应列,y 1, y 2对应行。
 

Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
 

Sample Input
 
 
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3
 
Sample Output
 
 
no

yes



解答:

#include<iostream>  
#include<queue>
#include<cstdio>  
#include<cstring>  
#include<algorithm> 
#include<vector> 
#include<cmath>  
#include<sstream>
#include<cstdlib>
#include<map>
const int N =105;
int n,m,k;
int sx,sy,ex,ey;//起点和终点坐标和转弯最大次数 
int dir[4][2] = {{1,0},{-1,0},{0,-1},{0,1}}; 
struct position{
	int x,y,t;//坐标,转弯次数 
};

char d[N][N];
int vis[N][N];

using namespace std;
bool bfs(){
	queue<position> q;
	position temp;
	temp.x = sx;
	temp.y = sy;
	temp.t = -1;//第一次选择方向不算
	q.push(temp);
	vis[sx][sy] = 1;
	while(!q.empty()){
			position now = q.front(); q.pop();
		if(now.x == ex&&now.y == ey&&now.t <= k){
			return true;
		}
		for(int i = 0 ;i<4;i++){
			position tmp;
			tmp.x = now.x+dir[i][0];
			tmp.y = now.y+dir[i][1];
			tmp.t = now.t;
			while(d[tmp.x][tmp.y]!='*'&&1<=tmp.x&&tmp.x<=m&&1<=tmp.y&&tmp.y<=n){
				if(vis[tmp.x][tmp.y] == 0)
				{
					tmp.t = now.t + 1;
					vis[tmp.x][tmp.y] = 1;
					q.push(tmp);
				}
				tmp.x+=dir[i][0];
				tmp.y+=dir[i][1];
				
			}
		} 
	}
	return false;
}
int main(){
	int T;
	cin>>T;
	for(int cases = 1;cases<=T;cases++){
		scanf("%d%d",&m,&n);
		//初始化
		memset(vis,0,sizeof(vis));
		//输入图
		for(int i =1;i<=m;i++){
			for(int j =1;j<=n;j++){
				scanf(" %c",&d[i][j]);//前面加个空格 
			}
		}
		
		cin>>k>>sy>>sx>>ey>>ex;
		if(bfs()) cout<<"yes"<<endl;
		else cout<<"no"<<endl;
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值