At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.
Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS
, and ID_number
is a string with no more than 15 characters.
Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.
Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133
解题思路:
我刚看到这题的时候以为有点难度,后面细细的阅读了一下题目发现还挺简单的。
这就是一题字典序排列的题目,只要你会用sort就可以解出来了,用sort进行两次排序,分别找出最早到的ID和最晚出来的ID即可。
废话不多说,直接上AC代码。
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
struct node
{
string ID_number,Sign_in_time,Sign_out_time;
}door[1000];
bool camp(node a,node b)
{
return a.Sign_in_time<b.Sign_in_time;
}
bool camp1(node a,node b)
{
return a.Sign_out_time>b.Sign_out_time;
}
int main()
{
int M;
cin>>M;
for(int i=0;i<M;i++)
cin>>door[i].ID_number>>door[i].Sign_in_time>>door[i].Sign_out_time;
sort(door,door+M,camp);
cout<<door[0].ID_number<<" ";
sort(door,door+M,camp1);
cout<<door[0].ID_number;
return 0;
}