2017 Multi-University Training Contest - Team 1 1011 KazaQ's Socks

27 篇文章 0 订阅

KazaQ's Socks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
KazaQ wears socks everyday.

At the beginning, he has n pairs of socks numbered from 1 to n in his closets.

Every morning, he puts on a pair of socks which has the smallest number in the closets.

Every evening, he puts this pair of socks in the basket. If there are n1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k -th day.
 

Input
The input consists of multiple test cases. (about 2000 )

For each case, there is a line contains two numbers n,k (2n109,1k1018) .
 

Output
For each test case, output "Case # x : y " in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.
 

Sample Input
  
  
3 7 3 6 4 9
 

Sample Output
  
  
Case #1: 3 Case #2: 1 Case #3: 2 题意是说KazaQ有n双袜子,标号1到n放在柜子里,每天早上起床穿袜子选标号最小的一双。 然后晚上回来将穿过的扔到篮子里。当篮子里的袜子数量为n-1的时候,就把这些袜子洗一下, 第二天晚上再放回柜子里。问KazaQ在第K天穿的是哪一个标号的袜子

n=3时

n k ans

3 1 1

3 2 2

3 3 3

3 4 1

3 5 2

3 6 1

3 7 3

3 8 1

3 9 2

3 10 1

3 11 3

。。。。。。

n=4时 n k ans 4 1 1 4 2 2 4 3 3 3 4 4 4 5 1 4 6 2 4 7 3 4 8 1 4 9 2 4 10 4 4 11 1 4 12 2 4 13 3 4 14 1 4 15 2 4 16 4 。。。。。。

观察规律:前n天,第i天袜子是i,之后,天数-n,即i-n, n-1为周期,

第i天,(i-n)%(n-1) 不为0, 袜子为(i-n)%(n-1),

否则, (i-n)/(n-1)为奇数 袜子n-1

(i-n)/(n-1)为偶数,袜子为n

#include <iostream>
using namespace std;
typedef long long int ll;

int main()
{
    ll n, k;
    int gg = 1;
    while (cin >> n >> k)
    {
        cout << "Case #" << gg << ": ";
        gg++;
        if (k <= n)
        {
            cout << k << endl;
            continue;
        }
        else
        {
            ll m = (k - n) % (n - 1);
            if (m == 0)
            {
                m = n;
            }
            ll rare = (k - n) / (n - 1);
            if (m < n - 1)
            {
                cout << m << endl;
            }
            else
            {
                if (rare % 2)
                {
                    cout << n - 1 << endl;
                }
                else
                {
                    cout << n << endl;
                }
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值