1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10 6≤a,b≤10 6. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

我第一时间想到的是递归,因为输出数字永远只能从后面算。

#include<iostream>
using namespace std;
int a,b;
void std_print(int c, int i){
    if(c<10){
        cout<<c;
        if(i==3) cout<<',';
        return;
    }
    if(i==3){
        std_print(c,0);
        cout<<',';
        return;
    }
    std_print(c/10,i+1);
    cout<<c%10;
}
int main(){
    cin>>a>>b;
    int c=a+b;
    if(c<0){
        cout<<"-";
        c=-c;
    }
    std_print(c,0);
}

看到一个巧妙的方法:转为字符串,然后从头开始输出。遇到距离结尾是3的时候输出逗号。
原文链接:https://blog.csdn.net/zhang35/article/details/104033658

#include <iostream>
using namespace std;

int main(){
    int a, b;
    cin >> a >> b;
    a += b;
    if (a<0){
        cout << "-";
        a *= -1;
    }
    string s = to_string(a);
    int n = s.size();
    for (int i=0; i<n; i++){
        cout << s[i];
        if (i!=n-1 && (n-1-i)%3==0){
            cout << ",";
        }
    }
    cout << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值