The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.
Output Specification:
For each test case, print the total time on a single line.
Sample Input:
3 2 3 1
结尾无空行
Sample Output:
41
大意:电梯上升一层耗时6s,下降一层耗时4s,每一次需求停5s,求总时长。
直接处理即可,不要忘记更新电梯位置。
#include<iostream>
using namespace std;
int main(){
int N;
cin>>N;
int t=0;
int pos=0;
for(int i=0;i<N;i++){
int des;
cin>>des;
t+=des-pos>0?(des-pos)*6+5:(pos-des)*4+5;
pos=des;
}
cout<<t;
}