Heavy Transportation POJ - 1797 +最小值最大化||最大生成树

问题:

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题意:有n个城市,m条道路,在每条道路上有一个承载量,现在要求从1到n城市最大承载量,而最大承载量就是从城市1到城市n所有通路上的最大承载量。

思路一:用Floyd算法更新每一条路的最大承受载量。

代码一:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int s[1010][1010];
int main()
{
    int t,kk=1;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        int a,b,c;
        memset(s,0,sizeof(s));
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            s[a][b]=s[b][a]=c;
        }
        int dis[1200]= {0};
        for(int i=1; i<=n; i++)
            dis[i]=s[1][i];
        int book[1220]= {0};
        book[1]=1;
        for(int i=2; i<=n; i++)
        {
            int maxx=-1,u;
            for(int j=1; j<=n; j++)
                if(book[j]==0&&dis[j]>maxx)
                {
                    maxx=dis[j];
                    u=j;
                }
            book[u]=1;
            for(int k=1; k<=n; k++)
                if(dis[k]<min(dis[u],s[u][k]))
                    dis[k]=min(dis[u],s[u][k]);
        }
        printf("Scenario #%d:\n",kk++);
        printf("%d\n\n",dis[n]);
    }
    return 0;
}

思路二:用最大生成树写,先将承载量从大到小排序 用并查集进行合并,当找到1和n连通时,

输出结果即可。

代码二:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int f[1200];
struct node
{
    int x,y,hv;
} q[1100000];
int zmh(node a,node b)
{
    return a.hv>b.hv;
}
int getf(int v)
{
    if(f[v]==v)
        return v;
    else
        return f[v]=getf(f[v]);
}
int merge(int x,int y)
{
    int t1,t2;
    t1=getf(x);
    t2=getf(y);
    if(t1!=t2)
    {
        f[t2]=t1;
        return 1;
    }
    return 0;
}
int merge1(int x,int y)
{
    int t1,t2;
    t1=getf(x);
    t2=getf(y);
    if(t1!=t2)
        return 1;
    return 0;
}
int main()
{
    int t,k=1;
    scanf("%d",&t);
    while(t--)
    {
        int n,m,minn=0x3f3f3f3f;
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
            f[i]=i;
        for(int i=0; i<m; i++)
            scanf("%d%d%d",&q[i].x,&q[i].y,&q[i].hv);
        sort(q,q+m,zmh);
        for(int i=0; i<m; i++)
        {
            int flag=merge(q[i].x,q[i].y);
            if(flag==1)
                minn=min(minn,q[i].hv);
            if(merge1(1,n)==0)
                break;
        }
        printf("Scenario #%d:\n",k++);
        printf("%d\n\n",minn);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值