PAT 1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

问题简单,有几个小坑注意下就可以了。

#include <cstdio>
#include <cmath>

using namespace std;

int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m))
    {
        char a[10];
        int ans = n+m,s=0,l=0,flag=0;
        if(ans<0)  //如果小于零,标记,后面输出负号
            flag = 1;
        ans = abs(ans);
        if(!ans)
            printf("%d\n",ans);
        else{
            while(ans){
                a[l++]=ans%10+'0';
                s++;
                ans/=10;
                if(s==3 && ans){ //每有3个数且前面还有数的时候添加逗号
                    s=0;
                    a[l++] = ',';
                }

            }
            if(flag)
                a[l]='-';
            else
                l--;
            for(int i=l; i>=0; i--)
                printf("%c",a[i]);
            printf("\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值