Poj 1654 Area 计算面积 解题报告

Description

这里写图片描述
You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.

For example, this is a legal polygon to be computed and its area is 2.5:

Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.

Output

For each polygon, print its area on a single line.
Sample Input

4
5
825
6725
6244865

Sample Output

0
0
0.5
2

题意

一个人会从原点出发,走一圈回到原点,给你路径,求围成面积的大小

思路

神题神题!!
首先路径不需要全部记录,读一个面积加上一部分叉乘即可
于是需要记录上一个点的坐标
然后面积只有可能是整数或整数加二分之一
所以用long long记录二倍面积,加快速度

我就必须吐槽了!!!

首先GCC会ce,G++会wa,不要用这两个编译器。

最终答案是要取绝对值,但fabs用c++居然会ce,所以要手写abs

因为答案一定是整数或整数除以二,所以用整形存,不能用float或double。

还有答案可能爆int,所以要开longlong。

最坑的是不能所有的变量都开,会MLE,所以只开跟答案相关的就行。

真的不知道第一个AC的人是这么做到的。。。

代码

没遇见这么无语的水题。。。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<vector>
using namespace std;
const double EPS=1e-10;
const int N=24;
int a[10]={0,-1,0,1,-1,0,1,-1,0,1};    
int b[10]={0,-1,-1,-1,0,0,0,1,1,1};
int abs(long long x)
{
    if (x<=0) return -x;
    else return x;
}
int main() 
{
    int q;
    char tmp[2];
    scanf("%d", &q);
    while (q--) 
    {
        long long x=0,y=0,area=0,px=0,py=0;
        int op;
        while (1) 
        {
            scanf("%1s",tmp);
            if (tmp[0]=='5') break;
            op=tmp[0]-'0';
            x+=a[op],y+=b[op];
            area+=px*y-py*x;//叉乘
            px=x,py=y;//更新上一个坐标
        }
        long long ans=abs(area);
        if (ans%2==0) printf("%lld\n",ans/2);
        else printf("%lld.5\n",ans/2);
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值