Hdu 5750 Dertouzos 素数筛 解题报告

Problem Description

A positive proper divisor is a positive divisor of a number n, excluding n itself. For example, 1, 2, and 3 are positive proper divisors of 6, but 6 itself is not.

Peter has two positive integers n and d. He would like to know the number of integers below n whose maximum positive proper divisor is d.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:

The first line contains two integers n and d (2≤n,d≤109).

Output

For each test case, output an integer denoting the answer.

Sample Input

9
10 2
10 3
10 4
10 5
10 6
10 7
10 8
10 9
100 13

Sample Output

1
2
1
0
0
0
0
0
4

思路

这道题先打表打一个素数筛,然后在主函数里面特判。

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<vector>
using namespace std;
const int N=100000+5;  
int T,n,m,isprime[N],primelist[N],top=1;  
void prime()
{
    for (int i=2;i<=N;i++)
    {
        if (isprime[i]==0)
        {
            for (int j=2;j*i<=N;j++)
            isprime[i*j]=1;
            primelist[top]=i;
            top++;
        }
    }
}
int main()
{
    scanf("%d",&T);
    prime();
    while(T--)
    {
        int i;
        scanf("%d%d",&m,&n);
        for (i=1;i<=top;i++)
        {
            if (n*primelist[i]>=m) break;
            if (n<primelist[i]) break;
            if (n%primelist[i]==0) break;
        }
        if (n*primelist[i]>=m||n<primelist[i]) i--;
        printf("%d\n",i);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值