Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 17044 | Accepted: 11902 |
Description
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
.
Given an integer n, your goal is to compute the last 4 digits of Fn.
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
Sample Input
0 9 999999999 1000000000 -1
Sample Output
0 34 626 6875
Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
.
#include<iostream>
using namespace std;
#define ll long long
const int mod = 10000;
ll Mod(ll x)
{
return x % mod;
}
struct mat
{
ll m[2][2];
}unit;
mat operator * (mat a, mat b)
{
mat ans;
ll x;
for(int i = 0; i < 2; i++)
{
for(int j = 0; j < 2; j++)
{
x = 0;
for(int k = 0; k < 2; k++)
x += Mod(Mod(a.m[i][k]) * Mod(b.m[k][j]));
ans.m[i][j] = Mod(x);
}
}
return ans;
}
void init()
{
for(int i = 0; i < 2; i++)
for(int j = 0; j < 2; j++)
if(i == j)
unit.m[i][j] = 1;
else
unit.m[i][j] = 0;
return;
}
mat Pow(mat a, ll b)
{
mat ret = unit;
while(b)
{
if(b & 1)
ret = ret * a;
a = a * a;
b >>= 1;
}
return ret;
}
int main()
{
ll n;
while(cin >> n)
{
if(n == -1)
break;
init();
mat mm, nn;
mm.m[0][0] = mm.m[0][1] = mm.m[1][0] = 1;
mm.m[1][1] = 0;
nn = Pow(mm, n);
cout << nn.m[0][1] << endl;
}
return 0;
}