POJ 1936 All in All(string)


All in All
Time Limit: 1000MS Memory Limit: 30000K
   

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

题目大意:

问是否字符串1是字符串2的子列。

解题思路:

对第一个字符串进行枚举,然后和第二个字符串匹配,匹配正确记录位置,然后进行下一个字符的匹配。(匹配是找离当前最近的并且靠右的)。

代码:

#include<iostream>
#include<cstdio>
#include<string>

using namespace std;

string str1,str2;

void solve(){
    bool ans = true;
    int pos=0;
    for(int i=0;i<str1.length();i++){
            for(int j=pos;j<str2.length();j++){
                if(str1[i]==str2[j]){
                    pos=j+1;
                    break;
                }
                if(j==str2.length()-1&&str2[j]!=str1[i]){
                    ans =false;
                }
            }
    }
    if(!ans) printf("No\n");
    else printf("Yes\n");
}

int main(){
    while(cin>>str1>>str2){//cin都是以空格,tab,换行结束的,getline是以换行结束的.
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值