A1023 Have Fun with Numbers (20分)【C语言】

A1023 Have Fun with Numbers (20分)【C语言】

原题链接

题目描述:
Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

输入格式:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

输出格式:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

输入样例:

1234567899

输出样例:

Yes
2469135798

实现代码:

#include <cstdio>
#include <cstring>

struct bign{ //大整数结构体 
	int d[21];
	int len;
	bign(){
		memset(d, 0, sizeof(d));
		len = 0;
	}
};

bign change(char str[]){ //字符串转为大整数 
	bign a;
	a.len = strlen(str);
	for(int i=0; i<a.len; ++i){
		a.d[i] = str[a.len-i-1] - '0';
	}
	return a;
}

bign add(bign a, bign b){ //大整数加法 
	bign c;
	int carry = 0;
	for(int i=0; i<a.len; ++i){
		int temp = a.d[i] + b.d[i] + carry;
		c.d[c.len++] = temp % 10;
		carry = temp / 10;
	}
	if(carry != 0){
		c.d[c.len++] = carry;
	}
	return c;
}

bool Judge(bign a, bign b){ //判断b的所有位是不是a的所有位的排列 
	if(a.len!=b.len) return false; //如果二者的长度不同,则一定不是 
	int count[10]={0}; //计数大整数中0~9出现的次数 
	for(int i=0; i<a.len; ++i){
		count[a.d[i]]++; //a中出现时计数加1 
		count[b.d[i]]--; //b中出现时计数减1 
	}
	for(int i=0; i<10; ++i){
		if(count[i]!=0) return false; //只要有一个数字的个数不对应,就不正确 
	}
	return true;
}

void print(bign a){ //输出大整数 
	for(int i=a.len-1; i>=0; --i){
		printf("%d", a.d[i]);
	}
}

int main()
{
	char str[21];
	scanf("%s", str);
	bign a = change(str);
	bign b = add(a, a);
	if(Judge(a, b)) printf("Yes\n");
	else printf("No\n");
	print(b);
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值