POJ 3254 Corn Fields (状压DP)

任重而道远

状压DP入门题

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.


题目大意:农夫有一块地,被划分为m行n列大小相等的格子,其中一些格子是可以放牧的(用1标记),农夫可以在这些格子里放牛,其他格子则不能放牛(用0标记),并且要求不可以使相邻格子都有牛。现在输入数据给出这块地的大小及可否放牧的情况,求该农夫有多少种放牧方案可以选择(注意:任何格子都不放也是一种选择,不要忘记考虑!

AC代码:

#include<cstdio>
#include<cstring>

using namespace std;

const int mod = 1e8;
int dp[15][1 << 15], ca[15][15];
int n, m;
long long ans;

bool jud ( int x, int state ) {
	if (state & (state << 1)) return false;
	for (int i = 1; i <= m; i++) 
	  if (!ca[x][i])
	    if ((1 << (m - i)) & state) 
	      return false;
	return true;
}

int main () {
	scanf ("%d%d", &n, &m);
	memset (dp, 0, sizeof (dp));
	for(int i = 1; i <= n; i++) 
	  for(int j = 1; j <= m; j++) 
	    scanf ("%d", &ca[i][j]);
	dp[0][0] = 1;
	for (int i = 1; i <= n; i++)
		for (int j = 0; j < (1 << m); j++) {
		  if (jud (i, j)) {
		  	for (int k = 0; k < (1 << m); k++)
		  	    if (!(k & j))
		  	    dp[i][j] += dp[i - 1][k];
		  }
		if (i == n) ans = (ans + dp[i][j]) % mod;
        }
	printf ("%lld\n",ans);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值