bzoj 1660: [Usaco2006 Nov]Bad Hair Day 乱发节(单调栈)

1660: [Usaco2006 Nov]Bad Hair Day 乱发节

Time Limit: 2 Sec   Memory Limit: 64 MB
Submit: 1180   Solved: 577
[ Submit][ Status][ Discuss]

Description

Input

* Line 1: 牛的数量 N。

 * Lines 2..N+1: 第 i+1 是一个整数,表示第i头牛的高度。

Output

* Line 1: 一个整数表示c[1] 至 c[N]的和。

Sample Input

6
10
3
7
4
12
2

Sample Output

5


http://blog.csdn.net/jaihk662/article/details/77488664一样都是单调栈

只不过这个只用求其中一侧

把数组反过来维护一个非严格递增的序列即可


#include<stdio.h>
#include<stack>
using namespace std;
#define LL long long
stack<int> st;
LL a[80005];
int main(void)
{
	LL n, i, ans;
	while(scanf("%lld", &n)!=EOF)
	{
		ans = 0;
		for(i=1;i<=n;i++)
			scanf("%lld", &a[i]);
		for(i=n;i>=1;i--)
		{
			while(st.empty()==0 && a[st.top()]<a[i])
				st.pop();
			if(st.empty()==0)
				ans += st.top()-i;
			else
				ans += n+1-i;
			st.push(i);
		}
		printf("%lld\n", ans-n);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值