bzoj 1650: [Usaco2006 Dec]River Hopscotch 跳石子(二分)

1650: [Usaco2006 Dec]River Hopscotch 跳石子

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 721   Solved: 457
[ Submit][ Status][ Discuss]

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 <= L <= 1,000,000,000). Along the river between the starting and ending rocks, N (0 <= N <= 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L). To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river. Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 <= M <= N). FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

数轴上有n个石子,第i个石头的坐标为Di,现在要从0跳到L,每次条都从一个石子跳到相邻的下一个石子。现在FJ允许你移走M个石子,问移走这M个石子后,相邻两个石子距离的最小值的最大值是多少。

Input

* Line 1: Three space-separated integers: L, N, and M * Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

* Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4


二分答案,然后判断是否合法

注意英文题面中0和L也是两个石子,并且这两个石子不可移除


#include<stdio.h>
#include<algorithm>
using namespace std;
int n, m, a[50010];
int Jud(int x)
{
	int i, sum, temp;
	temp = 1, sum = 0;
	for(i=2;i<=n;i++)
	{
		if(a[i]-a[temp]<x)
			sum++;
		else
			temp = i;
	}
	if(sum>m)
		return 0;
	return 1;
}
int main(void)
{
	int len, i, l, r, mid;
	scanf("%d%d%d", &len, &n, &m);
	a[1] = 0, a[n+2] = len;
	for(i=2;i<=n+1;i++)
		scanf("%d", &a[i]);
	n += 2;
	sort(a+1, a+n+1);
	l = 1, r = len;
	while(l<r)
	{
		mid = (l+r+1)/2;
		if(Jud(mid))
			l = mid;
		else
			r = mid-1;
	}
	printf("%d\n", l);
	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值