bzoj 1645: [Usaco2007 Open]City Horizon 城市地平线(线段树扫描线)

1645: [Usaco2007 Open]City Horizon 城市地平线

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 732   Solved: 333
[ Submit][ Status][ Discuss]

Description

Farmer John has taken his cows on a trip to the city! As the sun sets, the cows gaze at the city horizon and observe the beautiful silhouettes formed by the rectangular buildings. The entire horizon is represented by a number line with N (1 <= N <= 40,000) buildings. Building i's silhouette has a base that spans locations A_i through B_i along the horizon (1 <= A_i < B_i <= 1,000,000,000) and has height H_i (1 <= H_i <= 1,000,000,000). Determine the area, in square units, of the aggregate silhouette formed by all N buildings.

N个矩形块,交求面积并.

Input

* Line 1: A single integer: N

* Lines 2..N+1: Input line i+1 describes building i with three space-separated integers: A_i, B_i, and H_i

Output

* Line 1: The total area, in square units, of the silhouettes formed by all N buildings

Sample Input

4
2 5 1
9 10 4
6 8 2
4 6 3

Sample Output

16



线段树扫描线模板题

求矩形面积和要比求周长和容易点

#include<stdio.h>
#include<algorithm>
using namespace std;
#define LL long long
typedef struct Tree
{
	int cnt;
	int s1;
}Tree;
Tree tre[322233];
typedef struct Line
{
	int x, y;
	int flag;
	bool operator < (const Line &b) const
	{
		if(x<b.x || x==b.x && flag<b.flag)
			return 1;
		return 0;
	}
}Line;
Line s[80005];
int pos[80005];
void Atonce(int l, int r, int x)
{
	if(tre[x].cnt>=1)
		tre[x].s1 = pos[r]-pos[l-1];
	else
	{
		if(l!=r)
			tre[x].s1 = tre[x*2].s1+tre[x*2+1].s1;
		else
			tre[x].s1 = 0;
	}
}
void Update(int l, int r, int x, int h, int val)
{
	int m;
	if(r<=h)
	{
		tre[x].cnt += val;
		Atonce(l, r, x);
		return;
	}
	m = (l+r)/2;
	Update(l, m, x*2, h, val);
	if(h>=m+1)
		Update(m+1, r, x*2+1, h, val);
	Atonce(l, r, x);
}
int main(void)
{
	LL ans;
	int n, i, x1, x2, cnt, h;
	scanf("%d", &n);
	cnt = 0;
	for(i=1;i<=n;i++)
	{
		scanf("%d%d%d", &x1, &x2, &h);
		s[++cnt].x = x1, s[cnt].y = h, s[cnt].flag = 1;
		s[++cnt].x = x2, s[cnt].y = h, s[cnt].flag = -1;
		pos[i] = h;
	}
	sort(pos+1, pos+n+1);
	n = unique(pos+1, pos+n+1)-(pos+1);
	sort(s+1, s+cnt+1);
	ans = 0;
	for(i=1;i<=cnt;i++)
	{
		h = lower_bound(pos+1, pos+n+1, s[i].y)-pos;
		Update(1, n, 1, h, s[i].flag);
		ans += (LL)tre[1].s1*(s[i+1].x-s[i].x);
	}
	printf("%lld\n", ans);
	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值