poj 2393 && bzoj 1680: [Usaco2005 Mar]Yogurt factory(贪心)

1680: [Usaco2005 Mar]Yogurt factory

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 311   Solved: 228
[ Submit][ Status][ Discuss]

Description

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week. Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt. Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.

酸奶的生产受到很多因素的影响,所以每个月的生产成本是变化的,其中第 i 个月的成本是每吨 Ci 元。奶牛可以提前里把酸奶做好,存在仓库里,等需要的时候再拿出来卖。存储在仓库里的酸奶,每吨酸奶存放一个月需要支付 S 元的维护费用,存放的时间可以任意长。假设工厂的产量是无限的,存储酸奶的仓库也是无限大的。请问为了满足订单的需要,奶牛生产这些酸奶最少要花多少钱?

Input

* Line 1: Two space-separated integers, N and S.

 * Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

• 第一行:两个整数 N 和 S,1 ≤ N ≤ 10000, 1 ≤ S ≤ 100• 第二行到第 N + 1 行:第 i + 1 行有两个整数 Ci 和 Ai,1 ≤ Ci ≤ 5000, 1 ≤ Ai ≤ 10000

Output

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

• 单个整数:表示生产酸奶的最小总费用

Sample Input

4 5
88 200
89 400
97 300
91 500

Sample Output

126900


贪心

每次看当前是用仓库里的牛奶更划算还是当天生产更划算

然后再判断是什么时候生产的牛奶放进仓库更优

#include<stdio.h>
#include<algorithm>
using namespace std;
#define LL long long
int a[10005], b[10005];
int main(void)
{
	LL sum;
	int i, n, m, temp;
	scanf("%d%d", &n, &m);
	for(i=1;i<=n;i++)
		scanf("%d%d", &a[i], &b[i]);
	sum = a[1]*b[1];
	temp = a[1];
	for(i=2;i<=n;i++)
	{
		temp += m;
		sum += min(temp, a[i])*b[i];
		temp = min(temp, a[i]);
	}
	printf("%lld\n", sum);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值