2018北京ICPC D. Frog and Portal(构造)

 

D : Frog and Portal

时间限制:1000ms  单点时限:1000ms  内存限制:512MB

描述

A small frog wants to get to the other side of a river. The frog is initially located at one bank of the river (position 0) and wants to get to the other bank (position 200). Luckily, there are 199 leaves (from position 1 to position 199) on the river, and the frog can jump between the leaves. When at position p, the frog can jump to position p+1 or position p+2.

How many different ways can the small frog get to the bank at position 200? This is a classical problem. The solution is the 201st number of Fibonacci sequence. The Fibonacci sequence is constructed as follows: F1=F2=1;Fn=Fn-1+Fn-2.

Now you can build some portals on the leaves. For each leaf, you can choose whether to build a portal on it. And you should set a destination for each portal. When the frog gets to a leaf with a portal, it will be teleported to the corresponding destination immediately. If there is a portal at the destination, the frog will be teleported again immediately. If some portal destinations form a cycle, the frog will be permanently trapped inside. Note that You cannot build two portals on the same leaf.

Can you build the portals such that the number of different ways that the small frog gets to position 200 from position 0 is M?

输入

There are no more than 100 test cases.

Each test case consists of an integer M, indicating the number of ways that the small frog gets to position 200 from position 0. (0 ≤ M < 232)

输出

For each test case:

The first line contains a number K, indicating the number of portals.

Then K lines follow. Each line has two numbers ai and bi, indicating that you place a portal at position ai and it teleports the frog to position bi.

You should guarantee that 1 ≤ K, ai, bi ≤ 199, and ai ≠ aj if i ≠ j. If there are multiple solutions, any one of them is acceptable.

样例输入

0
1
5

样例输出

2
1 1
2 1
2
1 199
2 2
2
4 199
5 5

 

题意:

青蛙在一条河的左边,它想去河的对岸,河中间有199个荷叶,编号1到199从左往右排成一排,可以假设河左岸位置是0,对岸位置为200,青蛙每次可以向右跳1步或者2步,现在你可以在其中一些荷叶上面设置传送装置,一旦青蛙到达有着传送装置的荷叶,那么它将会被强制瞬移到传送装置设置的位置(可能发生连锁反应),其中一个荷叶上最多只能设置一台传送装置,问如何设置传送装置使得到对岸有刚好m种不同方案

 

思路:

构造题嘛,理论上不停拿数据测AC代码看输出就会做了,因为重要的是怎么构造

可以从2的次方上考虑,假设你在位置x上,求到达位置200,方案数刚好为m,该如何设置传送装置?

  • 如果当前m是偶数,那么很显然可以在位置x+1上设一个传到x+3的传送门,在位置x+2上设一个传到x+1的传送门,这样的话你无论往前跳2步还是1步都是到达位置x+3上,这样问题就变成了你在位置x+3上,求到达位置200,方案数刚好为m/2,该如何设置传送装置
  • 如果当前m是奇数,那么很显然可以在位置x+1上设一个直接传到终点的传送门,在位置x+2不设传送门,这样问题就变成了你在位置x+2上,求到达位置200,方案数刚好为m-1,该如何设置传送装置

搞定,注意特判m=1和m=0的情况

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<map>
#include<string>
#include<math.h>
#include<queue>
#include<stack>
#include<iostream>
using namespace std;
#define LL long long
#define mod 1000000007
LL F[55] = {1,1,2};
int s1[250], s2[250];
int main(void)
{
	LL n;
	int cnt, i, now;
	for(i=3;i<=50;i++)
		F[i] = F[i-1]+F[i-2];
	while(scanf("%lld", &n)!=EOF)
	{
		if(n==0)
			printf("2\n1 1\n2 2\n");
		else if(n==1)
			printf("2\n1 199\n2 2\n");
		else
		{
			now = 1, cnt = 0;
			while(n!=1)
			{
				if(n%2==0)
				{
					s1[++cnt] = now, s2[cnt] = now+2;
					s1[++cnt] = now+1, s2[cnt] = now;
					now += 3;
				}
				else
				{
					s1[++cnt] = now, s2[cnt] = 199;
					now += 2;
					s1[++cnt] = now, s2[cnt] = now+2;
					s1[++cnt] = now+1, s2[cnt] = now;
					now += 3;
				}
				n /= 2;
			}
			s1[++cnt] = now-1, s2[cnt] = 199;
			printf("%d\n", cnt);
			for(i=1;i<=cnt;i++)
				printf("%d %d\n", s1[i], s2[i]);
		}
	}
	return 0;
}

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值