Mayor's posters (线段树入门+离散化)

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters’ size, their place and order of placement on the electoral wall.

Input
The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,… , ri.
Output
For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input
1
5
1 4
2 6
8 10
3 4
7 10
Sample Output
4

思路:
线段树的题目,首先是我的习惯,把左儿子定义为kl,右儿子定义为kr。
这道题的题意是求依次覆盖后的报纸最后能看到多少种颜色。
首先重点是数据范围高达10000000,依次开节点会爆内存,因此就需要把数据离散化了。
其次是区间的问题,由于离散化后会把数据压缩在一起,而忽略了中间的空隙。
例如:
1
3
1 10
1 4
6 10
这个数据最后可以看到三种颜色,但一般的离散化后会把
1 1 4 6 10 10 去重为 1 4 6 10 离散化 1 2 3 4
这样4和6之间的空隙就被忽略了。
这时候我们可以在排序去重后 离散化前遍历数据,当两个数据之间的差值大于1即有可能存在空隙时,插入一个新数据作为中间的隔板,那么这个问题就迎刃而解了。

//#include<bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
#define mid ((l+r)>>1)
#define lson k<<1,l,mid
#define rson k<<1|1,mid+1,r
#define kl k<<1
#define kr k<<1|1
using namespace std;
const int mx=1e5+5;
const int manx=mx*4;

int col[manx],a[manx],vis[manx],l[manx],r[manx];
int ans=0;
inline void push(int k)
{
    if(col[k]!=-1){
        col[kl]=col[kr]=col[k];
        col[k]=-1;
    }
}
inline void change(int L,int R,int l,int r,int c,int k)
{
    if(L<=l&&R>=r){
        col[k]=c;
        return ;
    }
    push(k);   //更新lazy
    if(L<=mid) change(L,R,l,mid,c,kl);
    if(R>mid) change(L,R,mid+1,r,c,kr);
}
inline void find(int l,int r, int k)
{
    if(col[k]!=-1){
        if(!vis[col[k]]) ans++;
        vis[col[k]]=1;
        return ;
    }
    if(l==r) return ;
    find(l,mid,kl),find(mid+1,r,kr);
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,index=0;
        ans=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d%d",&l[i],&r[i]);
            a[++index]=l[i];
            a[++index]=r[i];
        }
        sort(a+1,a+1+index); //先排序
        int m=unique(a+1,a+1+index)-a-1; //去重
        index=m; //去重后的数据个数
        for(int i=2;i<=m;i++)
            if(a[i]-a[i-1]>1) a[++index]=a[i-1]+1; //插入中点
        sort(a+1,a+1+index); //再次排序
    //    for(int i=1;i<=index;i++) cout<<a[i]<<endl;
        memset(vis,0,sizeof(vis));
        memset(col,-1,sizeof(col));
        for(int i=1;i<=n;i++)
        {
            int L=lower_bound(a+1,a+1+index,l[i])-a;
            int R=lower_bound(a+1,a+1+index,r[i])-a;
            change(L,R,1,index,i,1);
        }
        find(1,index,1);
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值