Prime Gap

Description

The sequence of n − 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime gap of length n. For example, ‹24, 25, 26, 27, 28› between 23 and 29 is a prime gap of length 6.

Your mission is to write a program to calculate, for a given positive integer k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.

Input

The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.

Output

The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise. No other characters should occur in the output.

Sample Input

10
11
27
2
492170
0

Sample Output

4
0
6
0
114


大体的题意:

给定一个数字,如果是素数那么就输出0就ok了,如果不是,就找到两边的第一个素数边界,然后输出左边的与右边素数的差。

打个素数表,然后直接找到,竟然没有超时。


#if 0
#include<iostream>
#include<cstring>
using namespace std;
const int MAX=1299999;
int a[MAX],k;
bool vis[MAX];

void fun()
{
	memset(vis,1,sizeof(vis));
	for(int i=2; i<=1299709; i++)
	{
		if(vis[i]==1)
		{
			for(int j=2; j*i<=1299709; j++)
			{
				vis[i*j]=0;
			}
		}
	}

	for(int i=1; i<=1299709; i++)
	{
		if(vis[i]==1)
		{
			a[k]=i;
			k++;
		}
	}
	
}


int main()
{
	int n;
	fun();
	

	
	while(cin>>n&&n)
	{
		if(vis[n]==1) 
		{
			cout<<"0"<<endl;	
		}
		else
		{
			for(int i=1; i<k; i++)
			{
				if(a[i]>n&&a[i-1]<n)
				{
					cout<<a[i]-a[i-1]<<endl;
					break;	
				}	
			}	
		}	
	}	
}
#endif








评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值