hdu 3549 网络流EK裸题

 

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 15898    Accepted Submission(s): 7517


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
      
      
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
      
      
Case 1: 1 Case 2: 2
 

Author
HyperHexagon
#include<bits/stdc++.h>
using namespace std;

const int N=1005;

int pre[N];       //保存增广路径上的点的前驱顶点
bool vis[N];
int map[N][N];    //残留网络容量

int s,t;          //s为源点,t为汇点
int n,m;

bool BFS()        //找增广路
{
    int i,cur;
    std::queue<int>Q;
    memset(pre,0,sizeof(pre));
    memset(vis,0,sizeof(vis));
    vis[s]=true;    Q.push(s);
    while(!Q.empty())
    {
        cur=Q.front();
        Q.pop();

        if(cur==t) return true;       //如果已达到汇点t,表明已经找到一条增广路径,返回true.
        for(i=1;i<=n;i++)
        {
            if(!vis[i]&&map[cur][i])  //只有残留容量大于0时才存在边
            {
                Q.push(i);
                pre[i]=cur;
                vis[i]=true;
            }
        }
    }
    return false;
}

int Max_Flow()
{
    int i,ans=0;
    while(true)
    {
        if(!BFS()) return ans;     //如果找不到增广路径就返回。
        int Min=999999999;
        for(i=t;i!=s;i=pre[i])     //通过pre[]数组查找增广路径上的边,求出残留容量的最小值。
            Min=std::min(Min,map[pre[i]][i]);
        for(i=t;i!=s;i=pre[i])
        {
            map[pre[i]][i]-=Min;
            map[i][pre[i]]+=Min;
        }
        ans+=Min;
    }
}

int main()
{
    int T,k=1;
    int u,v,c;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        s=1; t=n;
        memset(map,0,sizeof(map));
        while(m--)
        {
            scanf("%d%d%d",&u,&v,&c);
            map[u][v]+=c;
        }
        printf("Case %d: %d\n",k++,Max_Flow());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值