HDU 5584 LCM Walk

LCM Walk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 442    Accepted Submission(s): 232


Problem Description
A frog has just learned some number theory, and can't wait to show his ability to his girlfriend.

Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered 1,2, from the bottom, so are the columns. At first the frog is sitting at grid (sx,sy) , and begins his journey.

To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid (x,y) , first of all, he will find the minimum z that can be divided by both x and y , and jump exactly z steps to the up, or to the right. So the next possible grid will be (x+z,y) , or (x,y+z) .

After a finite number of steps (perhaps zero), he finally finishes at grid (ex,ey) . However, he is too tired and he forgets the position of his starting grid!

It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach (ex,ey) !
 

Input
First line contains an integer T , which indicates the number of test cases.

Every test case contains two integers ex and ey , which is the destination grid.

1T1000 .
1ex,ey109 .
 

Output
For every test case, you should output " Case #x: y", where x indicates the case number and counts from 1 and y is the number of possible starting grids.
 

Sample Input
  
  
3 6 10 6 8 2 8
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 3
 

Source

2015ACM/ICPC亚洲区上海站-重现赛(感谢华东理工)

题意:任取一个点(x, y),它的下一个点应该是(x+z, y)或(x, y+z),z为x,y的最小公倍数,现在给出一个终点(ex, ey),问有多少个点出发可以走到这个终点。

思路:

首先

1.加上z之后的数一定是x,y里最大的那个数

2.证明gcd(x+z, y) = gcd(x, y)

根据辗转相除法求最大公约数:设两数种最大的为a, 则a 除于 b 得到 c 余 r1, 当 r1为0时结果就是b,否则再用b 除于 r1重复上一步。

那么当y是x的倍数时候,gcd(x+z, y)=gcd(x, y)=x,x和y不是倍数关系时候,(x+z) 除于 y的余数一定是x【z和y都能被y整除】,那么下一步就和求x,y的最大公约数的方法一样了。

由此得证gcd(x+z, y)=gcd(x, y)。

3.x和y的最小公倍数 = x*y/gcd(x,y)

所以x1+z = x1 + x1*ey/gcd(x1, y) = x1 + x1*ey/gcd(ex, ey) = ex, 化简得:x1 = ex/(1 + gcd(ex, ey)) 并且 ex是(1 + gcd(ex, ey))的倍数、gcd(x1, ey) = gcd(ex, ey)。

就这样不断求下一步直到没法求为止。

#include <stdio.h>
#define ll long long int
ll gcd(ll a, ll b){
    if(b == 0) return a;
    return gcd(b, a % b);
}
int res;
void Find(ll x, ll y){
    if(y > x){
        ll t = x;
        x = y;
        y = t;
    }
    ll g = gcd(x, y);
    ll tt = x*g/(g+y);
    if((g + y != 0)&&(x*g%(g+y)==0)&&(gcd(tt, y) == gcd(x, y))){
        res++;
        ll t = x*g/(g+y);
        Find(x*g/(g+y), y);
    }
}
int main()
{
    int T, k = 1;
    ll x, y;
    scanf("%d", &T);
    while(T--){
        scanf("%I64d %I64d", &x, &y);
        res = 1;
        Find(x, y);
        printf("Case #%d: %d\n",k++, res);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值