poj 3984 迷宫问题 【两种风格的队列+bfs】

题目链接:http://poj.org/problem?id=3984

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 34700 Accepted: 19732

Description

定义一个二维数组: 

int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

思路:这道题真心不会,代码抄的,现贴上,后面自己摸索出一种方法(flag)! j第二个上映了,谢谢自己的努力,第一个我打算放弃了

【1】

#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
const int maxn = 5;
//都不想多说,开个数组都能re

int vis[maxn][maxn];
int map1[maxn][maxn];
int dis[4][2] = {1,0,-1,0,0,1,0,-1};

struct node{
    int x;
    int y;
    int cnt;
    int step;
    int l[15];
    bool friend operator < (node a,node b)
    {
        return a.step > b.step;
    }
}; //讲道理,我真没看出这个step有啥用,我觉得没用

bool check(int x,int y)
{
    if(x>=0 && x<5 && y>=0 && y<5 && map1[x][y] == 0 && !vis[x][y])
        return true;
    return false;
}
//上面是进行判断。下面进行bfs调用

node bfs()
{
    memset(vis,0,sizeof vis);
    priority_queue<node>que;
    node e1,e2;
    e1.x = 0,e1.y = 0,e1.step = 0;
    que.push(e1);
    vis[e1.x][e1.y] = 0;
    e1.cnt = 0;
    while(!que.empty())
    {
        e1 = que.top();
        que.pop();
        if(e1.x == 4 && e1.y == 4)
            return e1;
        for(int i=0;i<4;i++)
        {
            e2 = e1;
            e2.x = e1.x + dis[i][0];
            e2.y = e1.y + dis[i][1];
            e2.l[e2.cnt++] = i; //记录路径
            if(check(e2.x,e2.y))
            {
                vis[e2.x][e2.y] = 1;
                que.push(e2);
            }
        }
    }
}

int main()
{
    //走程序
    ios::sync_with_stdio(false);
    for(int i=0;i<5;i++)
    {
        for(int j=0;j<5;j++)
        {
            cin>>map1[i][j];
        }
    }
    node e = bfs();
    int x = 0;
    int y = 0;
    cout<<'('<<'0'<<','<<' '<<'0'<<')'<<endl;
    for(int j=0;j<e.cnt;j++) //将路径打出
    {
        x += dis[e.l[j]][0];
        y += dis[e.l[j]][1];
        cout<<'('<<x<<','<<' '<<y<<')'<<endl;
    }
    return 0;
}

【2】更推荐第二个,有利于理解队列!

#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
const int maxn = 5;
//都不想多说,开个数组都能re

int vis[maxn][maxn];
int map1[maxn][maxn];
int dis[4][2] = {1,0,-1,0,0,1,0,-1};

struct node{
    int x;
    int y;
    int pre;
}q[30];

bool check(int x,int y)
{
    if(x>=0 && x<5 && y>=0 && y<5 && map1[x][y] == 0 && !vis[x][y])
        return true;
    return false;
}
void print(int pos) //递归将路径打印出来
{
    if(q[pos].pre != -1)
    {
        print(q[pos].pre);
        cout<<'('<<q[pos].x<<','<<' '<<q[pos].y<<')'<<endl;
    }
}

void bfs()
{
    int front = 0;
    int head = 1;
    q[front].x = 0;
    q[front].y = 0;
    q[front].pre = -1;
    while(front < head)
    {
        for(int i=0;i<4;i++)
        {
            int x1 = q[front].x + dis[i][0];
            int y1 = q[front].y + dis[i][1];
            if(check(x1,y1))
            {
                vis[x1][y1] = 1;
                q[head].x = x1;
                q[head].y = y1;
                q[head].pre = front; //记录路径
                head++;
            }
            if(x1==4 && y1==4)
                print(front);
        }
        front++;
    }
}

int main()
{
    ios::sync_with_stdio(false);
    for(int i=0;i<5;i++)
    {
        for(int j=0;j<5;j++)
        {
            cin>>map1[i][j];
        }
    }
    memset(vis,0,sizeof vis);
    cout<<'('<<'0'<<','<<' '<<'0'<<')'<<endl;
    bfs();
    cout<<'('<<'4'<<','<<' '<<'4'<<')'<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
回答: 广度优先算法可以用来解决迷宫问题。在迷宫问题中,我们可以使用一个二维数组来表示迷宫的状态,其中墙的位置用1表示,可以走的位置用0表示。通过设置一个vis\[\]数组来记录每个顶点是否被访过,vis\[i\]为0表示未被访,vis\[i\]为1表示已被访。通过广度优先搜索算法,我们可以找到从出口到入口的路径。具体步骤是将起点加入队列,然后不断从队列中取出顶点,并将其周围未访过的顶点加入队列,直到找到出口。同时,我们可以使用一个pre指针来指向每个顶点的前一个顶点,以便最后找出完整的路径。\[1\] 引用\[2\]中提到了如何用一个二维数组初始化迷宫,并归定不同的迷宫数组状态。例如,maze\[i\]\[j\]=0表示可以走,maze\[i\]\[j\]=1表示墙,maze\[i\]\[j\]=2表示无法继续走,maze\[i\]\[j\]=3表示已经走过的路径。 需要注意的是,迷宫问题可能会遇到时间限制,因此在实际应用中需要考虑算法的效率和优化。\[3\] #### 引用[.reference_title] - *1* [利用广度优先搜索(bfs)来解决迷宫问题](https://blog.csdn.net/weixin_45843077/article/details/104383595)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* [利用广度优先和深度优先算法解决迷宫问题【算法设计与分析】图搜索题>](https://blog.csdn.net/weixin_50400808/article/details/122571191)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *3* [广度优先搜索(BFS)——迷宫问题(POJ 4127)](https://blog.csdn.net/weixin_44572229/article/details/119679593)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值