HDU 2199 Can you solve this equation? 二分水题

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17700    Accepted Submission(s): 7873


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 

Sample Output
  
  
1.6152 No solution!
 

Author
Redow
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2899  2289  2298  2141  3400 
 

题意很明确,就是给你一个y,求出来对应的x,结果保留4位小数,本来想用暴力直接搜,但头介绍用二分法优化一下,可以避免超时,就没直接暴力搜索,二分法也很简单,答案肯定在0-100之间(题意给的),所以没有答案的我这里返回-1.
ac代码
<span style="font-size:18px;"><strong>#include <stdio.h>

int jdg(double head,double tail)
{
	if(head>=tail)
		return 1;
	
	return 0;
}

double result(double x)
{
	return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}

double bin(double head,double tail,double value)
{
	double mid;
	
	if(value<6||value>807020306)
		return -1;
	mid=(head+tail)/2;
	
	while(!jdg(head,tail))
	{//防止精度过大,
		if((-1e-5)<(result(mid)-value)&&(result(mid)-value)<(1e-5))
			return mid;
		else if(result(mid)<value)
			head=mid;
		else
			tail=mid;
		
		mid=(head+tail)/2; 
		
	}
	
	return mid;
}

int main()
{
	int t;
	double y,ans;
	
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf",&y);
		ans=bin(0,100,y);
		
		if(ans<0)
			printf("No solution!\n");
		else
			printf("%.4lf\n",ans);
	}
	
	return 0;
}</strong></span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值