hdu1081 To The Max--DP(最大子矩阵和)

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1081


一:原题内容

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 
Output
Output the sum of the maximal sub-rectangle.
 
Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 
Sample Output
  
  
15

二:分析理解

这道题前身是求一维数组的最大子序列和。这题只是二维而已。


三:AC代码

#include<iostream>  
#include<string.h>
#include<algorithm>  

using namespace std;

int map[110][110];

int main()
{
	int n;
	int x;

	while (~scanf("%d", &n))
	{
		memset(map, 0, sizeof(map));

		for (int i = 1; i <= n; i++)
			for (int j = 1; j <= n; j++)
			{
				scanf("%d", &x);
				map[i][j] += (x + map[i][j - 1]);
			}

		int ans = -1000000;

		for (int i = 1; i <= n; i++)//第i列
		{
			for (int j = i; j <= n; j++)//第j列
			{
				int maxx = 0;

				for (int k = 1; k <= n; k++)//第k行
				{
					if (maxx < 0)
						maxx = 0;

					maxx += (map[k][j] - map[k][i - 1]);

					if (maxx > ans)
						ans = maxx;
				}
			}
		}

		printf("%d\n", ans);
	}

	return 0;
}





  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值