[数据结构学习日记]PTA-Root of AVL Tree

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

 

#include <iostream>
using Position = struct AVLNode*;
using AVLTree = Position;
struct AVLNode {
	int Data{ 0 };
	AVLTree Left{ nullptr };
	AVLTree Right{ nullptr };
	int height{ 0 };
};
int GetHeight(AVLTree T) {
	if (T == nullptr) {
		return -1;
	}
	else {
		return T->height;
	}
}
AVLTree SingleRotateWithLeft(AVLTree T) {
	AVLTree B = T->Left;
	T->Left = B->Right;
	B->Right = T;
	T->height = std::max(GetHeight(T->Left), GetHeight(T->Right)) + 1;
	B->height = std::max(GetHeight(B->Left), GetHeight(B->Right)) + 1;
	return B;
}//LL旋转
AVLTree SingleRotateWithRight(AVLTree T) {
	AVLTree B = T->Right;
	T->Right = B->Left;
	B->Left = T;
	T->height = std::max(GetHeight(T->Left), GetHeight(T->Right)) + 1;
	B->height = std::max(GetHeight(B->Left), GetHeight(B->Right)) + 1;
	return B;
}//RR旋转
AVLTree DoubleRotateWithLeft(AVLTree T) {
	T->Left = SingleRotateWithRight(T->Left);
	return SingleRotateWithLeft(T);
}//LR旋转
AVLTree DoubleRotateWithRight(AVLTree T) {
	T->Right = SingleRotateWithLeft(T->Right);
	return SingleRotateWithRight(T);
}//RL旋转
AVLTree Insert(AVLTree T, int num) {
	if (T == nullptr) {
		T = new struct AVLNode;
		T->Data = num;
	}
	else {
		if (num < T->Data) {
			T->Left = Insert(T->Left, num);
			if (GetHeight(T->Left) - GetHeight(T->Right) > 1) {
				if (num < T->Left->Data) {
					T = SingleRotateWithLeft(T);
				}
				else {
					T = DoubleRotateWithLeft(T);
				}
			}
		}
		else if (num > T->Data) {
			T->Right = Insert(T->Right, num);
			if (GetHeight(T->Right) - GetHeight(T->Left) > 1) {
				if (num > T->Right->Data) {
					T = SingleRotateWithRight(T);
				}
				else {
					T = DoubleRotateWithRight(T);
				}
			}
		}
		else {
			// T->Data == num;
			// Do nothing;
		}
	}
	T->height = std::max(GetHeight(T->Left), GetHeight(T->Right))+ 1;
	return T;
}
int main() {
	AVLTree T = nullptr;
	int N, num;
	std::cin >> N;
	for (int i = 0; i < N; i++) {
		std::cin >> num;
		T = Insert(T, num);
	}
	if (T != nullptr) {
		std::cout << T->Data << std::endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值