面向对象程序设计上机练习一(函数重载)
Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
利用数组和函数重载求5个数最大值(分别考虑整数、单精度、长整数的情况)。
Input
分别输入5个int型整数、5个float 型实数、5个long型正整数。
Output
分别输出5个int型整数的最大值、5个float 型实数的最大值、5个long型正整数的最大值。
Example Input
11 22 666 44 55 11.11 22.22 33.33 888.88 55.55 1234567 222222 333333 444444 555555
Example Output
666 888.88 1234567
#include <iostream>
using namespace std;
int main()
{
int t = 5;
int x,max1 = 0;
float y,max2 = 0;
long long int z,max3 = 0;
while(t--)
{
cin >> x;
max1 = max(max1,x);
}
t = 5;
while(t--)
{
cin >> y;
max2 = max(max2,y);
}
t = 5;
while(t--)
{
cin >> z;
max3 = max(max3,z);
}
cout << max1 << endl;
cout << max2 << endl;
cout << max3 << endl;
return 0;
}