Rightmost Digit

Given a positive integer N, you should output the most right digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2
3
4
Sample Output
7
6


        
  
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

题目很好理解:求N的N次方的个位数。有多种做法:
第一种直接暴力,数太大,GG,想都不用想肯定会超时,运行WA
#include<bits/stdc++.h>//错误做法 
using namespace std;	
int main()
{
	int n;
	int x;
	int sum=0;

	while(cin>>n)
	{
		cin>>x;
	    sum=pow(x,x);
	    sum=sum%10;
		cout<<sum<<endl;
	} 
    return 0;
} 
第二种找规律: 当   n = 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 27 28 29 30 31 ...
rdigit = 1 4 7 6 5 6 3 6 9   0   1   6   3   6   5    6   7   4    9   0   1    4   7   6    5   6   3   6    9    0  ...
*#include <stdio.h>
#include<iostream>
using namespace std;
int  rdigit[25] = {0,1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9,0};
int main ()
{
    int T , n ; 
    cin>>T;
    while (T -- )
    {
          cin>>n;
          printf ( "%d\n" , rdigit[n%20] ) ;
    }
    return 0 ;
}
第三种快速幂:()

#include <iostream>
#include <cstdio>
using namespace std;
int mod_exp(int a, int b, int c)  //快速幂取余a^b%c
{
    int res, t;
    res = 1 % c; 
    t = a % c;
    while (b)
    {
        if (b & 1)
        {
            res = res * t % c;
        }
        t = t * t % c;
        b >>= 1;
    }
    return res;
}
int main()
{
    int T;
    cin >> T;
    while (T--)
    {
        int n;
        cin >> n;
        cout << mod_exp(n, n, 10) << endl;
    }
    system("pause");
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值