HDU __5437 Alisha’s Party

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2513    Accepted Submission(s): 681


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v , and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the nth person to enter her castle is.
 

Input
The first line of the input gives the number of test cases, T , where 1T15 .

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1k150,000 . The door would open m times before all Alisha’s friends arrive where 0mk . Alisha will have q queries where 1q100 .

The ith of the following k lines gives a string Bi , which consists of no more than 200 English characters, and an integer vi , 1vi108 , separated by a blank. Bi is the name of the ith person coming to Alisha’s party and Bi brings a gift of value vi .

Each of the following m lines contains two integers t(1tk) and p(0pk) separated by a blank. The door will open right after the tth person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1th,...,nqth friends to enter her castle.

Note: there will be at most two test cases containing n>10000 .
 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

Sample Input
  
  
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
 

Sample Output
  
  
Sorey Lailah Rose
 

Source



当时网络赛没弄出来,弄到最后拿了个TLE。。。
优先队列,或者集合模拟过程也行。。代码是看别人的日志敲得。。区别是加了自己的理解注释。。。这个题让我顺带让我了一下优先队列

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
#define LL long long
#define N 150005

struct Node {
        int v,x;//v是价值,x是排队的序号
        char name[250];
        bool operator < (const Node &_t)const{
                if(_t.v == v) return x >_t.x;   //序号大的优先级小,所有队列顶端为序号小的,
                return v < _t.v;
        }       //赋予每个元素优先级
}fir[N];        //存储每个人信息的数组

struct query{
        int t,p;                //t表示第几个人来时开门,进p个人
        bool operator < (const query &_t)const {
                return t < _t.t;
        }

}que[N];        //存储出队的操作信息

priority_queue <Node> q;
int ans [N];

int main(){
        int T;
        int k,m,Q;
        int a;
        scanf("%d",&T);
        while(T--){
                scanf("%d%d%d",&k,&m,&Q);
                for(int i= 1;i <= k;++i){
                        scanf("%s%d",fir[i].name,&fir[i].v);
                        fir[i].x = i;
                }
                for(int i = 1;i <= m;++i){
                        scanf("%d%d",&que[i].t,&que[i].p);
                }
                sort(que + 1,que + m + 1);      //que[0]没有存储信息,注意que可能不是有序的,所以要排序
                int now = 1;                    //now标记que数组的指针表示第now次开门
                int cnt = 0;
                while(!q.empty()) q.pop();      //清空队列
                for(int i = 1;i <=k;i++){
                        q.push(fir[i]);
                        while(i == que[now].t && now <= m){     //每有一个人入队就要判断一下是否达到开门条件
                                for(int j = 1;j <= que[now].p && (!q.empty());j++){
                                        ans[++cnt] = q.top().x;
                                        q.pop();
                                }
                                now++;
                        }
                }
                while(!q.empty()){      //当门的次数开完之后,剩下的所有的人全部放进来
                        ans[++cnt] = q.top().x;
                        q.pop();
                }
                for(int i = 1;i <= Q;i++){
                        scanf("%d",&a);
                        if(i != 1) printf(" ");
                        printf("%s",fir[ans[a]].name);
                }
                printf("\n");
        }
        return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值