unity 开发oculus配置问题

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/LoHiauFung/article/details/88120344

一、较老的解决方案

这个连接的配置是可行的
https://blog.csdn.net/morphyyang/article/details/52914627#commentBox
但是问题在于,这个博客的驱动和unity版本太老了,用不了现在官方的SDK

二、我的解决方案

首先,你要有
一条梯子,
一条梯子,
一条梯子

因为不翻墙是做不了的

①安装unity2017.4.21f1 (Recommended)

这不是我瞎说的,是oculus官方说的
https://developer.oculus.com/documentation/unity/latest/concepts/unity-req/

②安装oculus驱动

旧版的驱动叫runtime 0.8,但是太老了。新的不叫runtime,叫setup,其实就是oculus的客户端,驱动内置到客户端里,不提供单独安装。
https://www.oculus.com/setup/
这个网站,左边这个,下载,然后安装,有十多G好像。
在这里插入图片描述

③ 登陆Oculus

然后到了这一步应该是登陆不上去的,有梯子也不行,要修改HOST.
参考这个连接,我现在是可以的。
https://blog.csdn.net/mo_qi_qi/article/details/83795668
如果失效了,就看下面这个连接自己手动找能用的HOST
https://blog.csdn.net/XIA_CHENGQI/article/details/80179607

④允许“未知来源”

‘设置" – “通用” – “未知来源”打开,不然自己的unity项目无法在头盔里显示。
在这里插入图片描述

⑤ unity 里面开启对VR 的支持

“Edit” – “Project Setting”–“player” – “XRSetting” – "Virtual Reality Supported"选中,即可。
在这里插入图片描述

⑥跑UNITY项目

此时,跑跑你的UNITY项目,就能在头盔看到效果了

展开阅读全文

没有更多推荐了,返回首页